Roon 2.0 and Linux (Wine) .. is 32bit needed? [answer: no, wine supports 64bit]

You beat me to it, @BlackJack! I’m using 4.7.2.

@Gracjan_Deresz, follow the steps in this thread that summarizes a Bottles installation.

I’ve updated the installer script over the last weekend, so 2.0 is now running again for those interested.

1 Like

It should work with 4.5 as well…

which script are you talking about?
does it work for arch?


nice will try that :smiley:
maybe that fixes the issue that no roon installation can see my audio devices :frowning:

Ouch, just forget about all my prior messages in this thread about Roon 2.0.5 or later not working on Linux/Wine.

I had made a mistake in my install script so .NET 4.8 was not installed.

Installed it correctly now and all is fine. No more crashes/hangs while selecting audio zone.


Alrighty. I’ve managed to get it running just by installing .NET 4.8 and… damn! It performs much better than on Windows which is hilarious.


do you use local audio resources for playback?

sadly my bottle test roon did not find any audio resources :frowning:

On the Linux box, install Roon Bridge.

i tried that too (just installing the linux bridge)
but sadly my SMSL 500 USB Dac seams to be found nowhere even tho it works totally fine with windows and linux as OS :confused:

Yes, DX5 connected to my PC with Linux.
I had roon bridge installed before but I can use all zones within roon bottle.

Make sure it’s enabled in roon settings?
Maybe OS restart?

got my bottled roon running again.
I don’t know why but this time at least it lists a few of my audio devices :smiley:

sadly there is no playback. When you chose a playlist there is a frame where it shows the track and than skips to the next. Takes a second for a playlist to skip through.
but no sound whatsoever not even a crack. :frowning:

interestingly the patch bay shows a working connection.


im running on the latest Manjaro with pipewire

I have a 2013 imac which was having boot trouble.
So yesterday i wiped it and put linux mint cinnamon on. My first experience of a linux distro. Imac is working again.

Anyways, ive got Roon / Wine running but have one issue.

When Roon app loads up, i can filter through all tabs, use search etc etc. But i cannot select an audio zone. I can click the button so the zones pop up, but as soon as i select a zone the app freezes and have to kill it.

Anybody have any wisdom as to what might cause this / any solutions from prior experience?

I had the same problem with crash/hang at selecting audio zone.

What fixed it for me was to install .NET 4.8 prior to installing Roon, using the winetricks script like:
winetricks dotnet48

Or just use the installer here that automates the entire Roon install including the .NET runtime:

1 Like

Ill give it a try.
I followed some other instructions where NET was indeed inslalled after roon.exe
Cant recall NET version either.

I did try the github you linked on my first try but I couldnt get Roon to start. Ended up with some “path doesnt exist” errors. I since saw a post about that in here so may try thst again also.

Cheers :+1:

installing net after roon was a fix for me too (:

does anyone also have a problem with replay tho?

Found success with Bottles on Mint.


After a long wait, I have a new Linux laptop.

I’m running Ubuntu 22.04.1 LTS., and installed Bottles via Flatpak with .NET 4.8. However, Roon was crashing as soon as I used mouse gestures to switch screen. The solution was to switch from soda-7.0-8 to sys-wine-7.0.1. Of possible interest is that CPU usage (for a single core) dropped from 100% to around 70%. However, CPU fan runs full tilt with Roon running. :frowning: