Roon 2.0 broke Roon Remote

I use Roon Remote on my Amazon Tablet to listen on my DCS Bartok DAC. After updating, Roon remote is incompatible, and there are no updates in the Play Store or the Amazon store.
Roon ARC os quite useless since it has no way to select the output device. The music comes from my tablet instead of my 20,000$ HiFi. Since Roon only works on my internal network, what is the point of a program that works on a phone or tablet when I can listen to much better quality on my Computer or HiFi?
So how do I get Roon Remote to work again with Roon 2.0 core? The helkp pages are not found either.

2 Likes

Same problem on my system. Why does Roon not provide a way to roll back to the previous software that worked perfectly.

Updated versions of Roon Remote are available in all of the app stores.

Roon ARC is for use outside of the house. Many people find that useful. If that’s not you, that’s not you.

If you want to roll back the instructions are here.

1 Like

It says my Roon core is not configured for external access. How do I get it?
And How do I get the latest versions of Room remote? I looked, and they have no updates.
I also have trouble connecting to my core. My phone (android) says 1.8 build 898 is incompatible.
The help page does not work.
Provioe links to the updated apps.

It just found an update in the Play store.
Now, How do I use Roon Arc outside my house. I opened the firewall port

What OS you on?

Read the faq about setting up ARC and remote access.

Linux. OpenSUSE LEAP 15.4

Remotes? Not core

There should be a “Start troubleshooting” button and a “More info” link. Else:

1 Like

Android and Amazon’s version of it

Amazon store is always slower to update than Google Play so possible the reason you don’t see it. It’s always best to only update when all versions are available for your platforms. You can roll back to 1.8 in the meantime until it’s readily available.

@brian is arc and remote still supported on Amazon AppStore can’t see any links to it.

I don’t see it on my Huawei without Google. Core is 2.0 and Remote says : incompatible. Maybe you can insert Remote in the download section?

I had to uninstall my Roon remote, which took about 10 minutes. But then downloading it again (the page said Roon 2,0) worked.
Also, Roon ARC works on my phone over T-Mobile.
But how does ARC know my dyndns ip address?

1 Like

Ok, I found apk file with 2.0 Remote. But anyway , it would be good to have update possibility from Roon page , not external .

Yes, it was necessary to delete Roon-remote on iPhone and install it again to switch to remote-version 2.0. No update found in App Store.

There is no new 2.0 Roon Remote for iPad. After I updated Roon server to 2.0, the Roon Remote on my iPad stopped working (could not connect to the new 2.0 server). To use Roon Remote on my iPad again, I had to delete the previously installed Roon Remote from my iPad. Download and relaunch the Roon Remote.

1 Like

There is a Roon Remote for iPad. It’s Roon 2.0 on the Apple App Store version 2.0.01127.

1 Like

This is an absolutely unacceptable disposition.

Given that the Roon server was updated via phone (it wasn’t clear that it was a ‘major’ upgrade) - had that been realized, this upgrade WOULD NOT HAVE BEEN DONE, at least not without reading the release notes. From the small ‘box’ of information that is presented, it was not clear that this was a major upgrade - thus it appeared like any other minor upgrade notice and didn’t think twice about hitting the update selection. Would strongly recommend that major version upgrades have some sort of color/font/… variation that is strikingly different from an incremental update. It should be reasonable for one to assert that an incremental update should be applied (even if mildly detrimental) while Roon folks work out the kinks and quickly provide a subsequent update. This is certainly not that.

Apparently, now one MUST run/accept/allow ARC. Whatever ‘connection’ is going on to exfiltrate data triggers IDS/IPS gear to immediate block the connection to/from the Roon server. Where is the disable option for ARC? This should not be mandatory, especially given lack of complete transparency and the ability to audit what is traversing this logical VPN connection.

Finally, decided to uninstall on each/every device to revert. However, the current issue is - how does one ‘revert’ for the application on an iPhone? iPad? etc… Apparently only the 2.0 application is available for install.

EDIT: The legacy app v1.8 is listed under the developer in the App store. However, it is constantly crashing within a few seconds of running. Re-deleted app and re-installed, now seems to be back to stable.

This is becoming a bit cumbersome and not leaving a particularly good impression.

1 Like

Maybe I’m missing something. I don’t have a use for ARC now, so have not installed it.

However, I was able to update to Roon 2.0 on my iMac, iPhone and iPad. First I updated the iMac. When I opened the app in either the iPhone or iPad, there was a message indicating the latest version on Roon core and provided a link to update the mobile apps. No problems for mac users.

So my Android phone updated to 2.0 I guess, now it refuses to connect to my Core unless I upgrade it.

So what are we supposed to do if we don’t upgrade to 2.0? Do we have to upgrade to 2.0 and force back to 1.8 legacy? Just install Legacy over the 1.8 we have installed? Go find new software?

Since my Core is running on Windows 7, and 2.0 drops support, I don’t think I can upgrade-then-downgrade without risking failure in the middle.