Roon 2.0 build 1148 - issues. Can’t open Core

Roon Core Machine

iMac mini, OsX 10.15

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

After update to build 1148 Roon Core can’t relaunch. I was running 2.0 previously without any issues. I have tried downloading Roon againg reinstalling but without any change.
It is stuck during opening until message about ending unexpected

Are you saying the roon remote can’t get to the core? What remote(s) being used? Did you update the remote from the apps store?

No. My Roon Core itself can’t relauch or open

The remotes are updated.
And as said I have also tried reinstalling the Core but still can’t lauch it

I had the same problem - but after some time, not sure how long but definitely longer than expected, the Core suddenly sprang into life and now all is good.

Hi Adrian
Thanks for sharing your experience.
My problem is that it doesn’t just keep on trying to open.
After “longer than expected” it stops with a system error that it stopped unexpected (free translation from my danish version)
From there I can choose to cancel or retry opening with the same result
Br. Peter

Hey @Peter_Hvidegaard,

Following up on this thread, are you still running into issues getting your core to boot up? I’d like to enable diagnostics on your account, but we’re not able to connect to your Mac Mini.

If possible, would you be able to send us a set of manual logs from the core device you’re having issues with? Please use the directions found here and send over a set of logs to our File Uploader.

I’ll be monitoring this thread for your reply :+1:

Hi @benjamin
Thanks for following up.
Yes the problem still persist. No I would assume that connecting to the Mac mini would require that Roon is running, and that’s exactly the problem. I can’t open it.
I have uploaded the logs as requested with the name “”
I really hope for your assistance to be able to play using Roon again.
Please let me know how I can assist further.
Best regards, Peter

Hey @Peter_Hvidegaard,

Thank you for taking the time on this! As a next step, I’d like to get a fresh database going on your core to see how things function. Please follow the steps below:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Hey @benjamin
Tried as you suggested besides for obvious reasons I am not able to make a backup.

After reinstall it appeared to open up normally asking to either search for Core or use this as core.
I chose the latter and was asked for login.
Thereafter the program shut down with the same system message that roon stopped unexpected :frowning:
Best regards

Hey @Peter_Hvidegaard,

Thanks for giving that a try. It seems as though your core is having trouble reaching our servers. What are your DNS settings currently set to?

If possible, could you try setting your DNS to Google or Cloudflare, reboot your machine and router, and see if that helps?

Google is and
Cloudflare is and

Take note of your current DNS settings in case you’d like to revert this change :+1:

Well we can give it a try.
However it seems more like it is crashing on the system.
Just tried opening the new installation and from the screen just waiting for my input to search for Core or use this as Core the program shuts down.

I assume you mean the dns setting on the router?
That is just set to getting it from isp and the computer is just set to the router.
Or do you just want me to change settings on the computer with the Core installed?

Hey @benjamin
Tried changing the dns on the router to Google.
No change.
When trying to open roon it crashes and shuts the screen down.
I would have been surprised if that was the case.
Roon on other computers opens. (And they have the same dns settings. (Obviously opening other roon installations now they will just be waiting for the Core)
Best regards

Hey @Peter_Hvidegaard,

Thanks for giving that a try. In this case, I think performing a complete clean install of the app would be a good next step. Steps to follow below:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Let me know if the above helps :pray:

Hej again @benjamin
Tried your suggestion above but with the exact same result.
Downloads and installs. When opening I choose to set up as core, enter my login information and it completely shuts down with the same message of having closed unexpected.
:frowning: :frowning:
Really frustrating
Best regards, Peter

Hey @Peter_Hvidegaard,

Thanks for giving that a try. I’d be curious to see if you’d be able to set up Roonserver successfully, as a test run compared to using the full version of Roon.

In short Roonserver is a headless version of Roon, in which you can still set it up on your iMac. From there, you can download the roon remote app to your iMac, and it would function very similarly.

Here is more info on this:

And here is a step by step on migrating to Roonserver:

I’ll be on standby for your reply :+1:

I’m having the same problem. My Roon Core (Mac Mini M1) is running Roon 2.0 build 1149. I can’t access Roon from my Pixel 4a 5g phone or HP Spectre x360 PC, both of which are running Roon Core 2.0 build 1148. I get an incompatible versions error message

Hey @Gordon_Brockhouse,

Build 1149 is early access, so you’ll need to make sure your devices are also running early access. You can learn more and get the downloads needed below:

Hej @benjamin
Tried setting up the Roon server instead.
At first it looked like a success. Status on the Roon server was running and I managed to locate it on on the remotes before access was quickly interrupted.
I can now see the status switching between started, not responding, error
So sadly, no solution :frowning:
Best regards, Peter

I have no problem with Roon 2.0 as core on my MacBookPro, but I feel your pain and it is very pity :frowning: I would expect that the support will look at your machine via teamviewer and analyze the problem. Did you send the full error message to the support team?