Roon 2.0: Can't Connect to Core

I am struggling with same problem. some sort of upgrades happened and now no music. my core in upgraded to 2.0 and my iPhone is current model I believe Roon app is upgraded to 2.0 but no way for me to even check anything because when I turn on the app it starts looking for the core and never finds it. I can’t even go to any other screen. I have tried support in a similar thread and not help. this is really crappy help and in fact no help. I am without music for 3 days

1 Like

Did you download the newest Roon app from the App store?

yes, I did that and with same result. keep looking for core …

If your Core and iPhone are both on V2.0, you should be Ok.

Did you try rebooting the Core?

What kind of machine is the Core on and how do you know it updated?

core is sonic orbitor i5 which had been working fine for more than a year. I checked Roon version 2.0 on it by computer access. deleted and re downloaded current iPhone Roon Remote . No luck.

that would be nice…

I have Roon app 2.0 and Roon Server 2.0 on linux sonic orbital small green computer. Why can I not use Roon. it keeps looking for core.

Create your own support thread and fill in the requested information


@Usman_Qureshi, I have moved your posts, including replies, to a new #support thread. I’ve done this so your issue has visibility; the original thread is now solved.

Please complete the following template. Thanks.

Roon Core Machine

<!-- Include your operating system and machine info (Model, CPU, RAM) -‐>
<!-- Write below this line -‐>

Networking Gear & Setup Details

<!-- Your network gear (model of routers/switches) and if on WiFi/Ethernet, are you using YPN -‐>
<!-- Write below this line -‐>

Connected Audio Devices

<!-- Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.) -‐>
<!-- Write below this line -‐>

Number of Tracks in Library

<!-- Tell us how large your music library is, eg. “30,000 tracks” -‐>
<!-- Write below this line -‐>

Description of Issue

<!-- Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated! -‐>
<!-- Write below this line -‐>

3 posts were split to a new topic: Difficulties Switching to Roon 1.8 Legacy

thank you Martin. I already have a thread going but had NO SUPPORT from ROON for 4 days on that thread. luckily just now I was able to solve the issue with help of email from sonicorbitor. Having essentially NO product support from ROON is very annoying.

1 Like

The forum is very busy currently because of the new release. Moreover, you posted into another post when you should have opened your support thread.

Since you’ve solved the problem, I’ll mark your post as the solution.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.