Roon 2.0 - Crashing on MacOS due to ".NET ThreadPool Worker" [Roon Investigating]

I have no problem with Roon Core running 2.0 on Intel NUC10i7. But my remote on Mac mini, iPAD, etc kept crashing or freezing. Had to reboot frequently while music playing is OK. Rarely happened before the upgrade.

Not realising that this thread was running I opened my own ticket here Roon Core Repeatedly Crashes and as yet no response from Roon. It would appear that this is a serious issue with Roon 2.0 on Mac’s and deserves better customer service for it’s subscribers who are paying a handsome fee for an unusable product at the moment. My renewal is looming shortly and I will need to see some level of concern for our situation before I part with funds again.

2 Likes

3 posts were split to a new topic: Nucleus crashing on Roon 2.0

I’m seeing the same problem. M1 Mac Mini. Seems to happen when I am jumping around between songs — particularly Qobuz I think.

Hi All,

We are looking into this and gathering related reports. If you’re still seeing this issue, can you please upload your MacOS crash logs and Roon logs (Roon logs can be accessed by using these instructions) to the following link and let us know once uploaded? Thanks!

https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external

Are you running the server app with no UI or the app with the full UI?

I ask because I have been running the server app with no UI on my M1Mac mini running macOS Monterey Version 12.6 and have had zero issues.

1 Like

I’m running the full app. But I don’t really need to. It’s a headless machine. I only remote desktop into it to restart Roon. :slight_smile: So there’s a server app option?

Yes.

Scroll to the middle of the page.

1 Like

Adding in to the crash/freeze thread. Fairly identical stack dump as the OP happening on my end. Happens not every launch but frequently enough to cause fairly large issues since upgrading to 2.0. When launching in this bad state it will also freeze additional windows (Slack/Discord/Terminal/etc). Attached a screengrab from a trace showing the long hang.

My setup is purely local and playing out of system output.

My system:
Model: MacBookPro16,1, 8 processors, 8-Core Intel Core i9, 2.4 GHz, 32 GB, SMC
Graphics: Intel UHD Graphics 630, Intel UHD Graphics 630, Built-In
Graphics: AMD Radeon Pro 5500M, AMD Radeon Pro 5500M, PCIe, 8 GB

One thing I will note as well that every hang I get this in the logs. Other logs from clean starts (less than a second or two) are void of this exception.

10/18 17:43:17 Warn: exception starting raatserver: System.Net.Internals.SocketExceptionFactory+ExtendedSocketException (61): Connection refused 127.0.0.1:9004
at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
at System.Net.Sockets.Socket.Connect(IPAddress address, Int32 port)
at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
— End of stack trace from previous location —
at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
at System.Net.Sockets.TcpClient…ctor(String hostname, Int32 port)
at Sooloos.RAATServer.ConnectOrStartAndWaitForExit(String path, String args, Action`1 status, ChildProcess& p)

This seems linked to the behavior described in this other thread. Seems to be circulating around 2.0 release. Planning on moving back to 1.8 but will keep live for now if any additional information is needed.

It still crashes.
I’ve uploaded compressed log files.

One thing I noticed is that Roon Client didn’t crash at home and running very well but it crashes whenever I open the application at my office. ARC works very well at home, but I couldn’t even test ARC at my office.
As I know some ethernet ports are disabled for security reason at my office, so maybe can it be a network issue?
I hope that it could be some clue for debugging.

Noris -

I assume the technical team is still trying to determine the cause of the crash? My crashes have continued on both the Core running on my mac mini and my roon remote running on my MacBook Pro.

Given the lack of a fix so far, I have rolled back to Roon 1.8 following the original instructions plus the supplemental advice elsewhere on leaving the Roon remote active while rolling back the core. (I had previously tried to do so running 1.5 on an iPad, but the roll back failed). This attempt at a rollback was successful, and I was able to listen this weekend on several occasions without experiencing the .net crashes. I did have some occasional network stutters, which has happened before, and I mention in the unlikely case this is related to the .net crashes.

I’d ask that you leave this support thread open until such time as tech support identifies the problem and has a fix available, since the original issue with 2.0 is unresolved. Once the problem is fixed, I can attempt another upgrade. I would strongly urge Roon to continue the support for rollback to 1.8 beyond the initial 6 week period communicated previously. I would be extremely unlikely to upgrade and test a fix without a rollback option to fall back on.

Thanks for your help with this issue.

Hello All,

I wanted to reach out with an update. We have attempted to reproduce this issue in the QA lab, but have been unable to, even on similar model Macs as the ones reported in this thread. For those still impacted by this issue, can you kindly provide the following additional information?

  1. Is there one specific view in Roon that causes this issue to occur more frequently (Now Playing, Home, etc.)?

  2. Can you please let us know the exact local time + date of the next crash and upload the MacOS core report to the following link?

https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external

  1. What is the year, model and MacOS version of the affected device?

  2. Are you able to notice this issue only when on one specific network or have a certain networking interface active? As @SEUNG_HUN_LEE has below?

  1. Are you using Roon All-in-one (Core is controlled directly) or as a Remote connected to another Core?

  2. (Optional) If you try to run your Roon Core as a RoonServer background process and connect the Roon App to it from the same Mac, does the RoonServer process crash, the Roon App, or both? RoonServer setup details can be found here:

Please, do let us know if you are able to provide this information, thank you!

@noris, Thanks for the update, but sorry to hear you have not been able to nail the .NET crash down yet. I’ve rolled back to 1.8 which is working ok for me, so I’m reluctant to give it another go right now just to produce crash reports again. I’ll attempt to answer some of your questions regarding my prior crashes however.

  1. I believe all of my crashes occurred from the home screen. This is certainly true of the core crash on my 2018 Mac Mini which would crash once every hour or so. I run my core on a headless Mac Mini hardwire connected to a switch on my network. I had an occasion crash on my Roon remote running on a 2022 MacBook Pro, less than once a day. I cannot recall a crash while I was actively playing music or browsing the library.

  2. Not available due to rollback to 1.8

  3. Core runs on a 2018 Mac Mini i3 8 GB. Remote runs on a 2022 MacBook Pro M2 24GB. Both running macOS Monterey 12.6.

  4. All failures are on my home network. Core is hardwire connected via NetGear switch. Remote is wireless connection to Eero Pro 6 home network.

I do think I have a bit of a noisy network. Streaming video services will occasionally report a dropped connection, but reconnect and continue playing generally with no interaction required. I’ve long though I must have a bad actor on the network as this condition has persisted through a change in internet service from cable to fiber and upgrade of home network equipment from original Eero devices to Eero Pro 6. However, I"ve been unable to isolate a problem device. Since rolling back to Roon 1.8, I get an occasional Unable to Connect to Core message on the client and music playback stops. However, Neither the remote or core app crashes and I am able to restart play immediately.

5&6. I’m running Roon all in one on my core machine. I’ve not attempted to run Roon Server. Failure is on the core machine running the all in one app most frequently, but have also had the Remote failures which have the same all in one app installed.

Thanks!

Hi there @Noris. I just submitted my error report as well. I have the exact same situation happening since upgrading to 2.0.

Chris

Wanted to drop an update here. While it is unfortunate the latest version doesn’t support rollback to 1.8 anymore my issue reported above seems to be resolved on the build that just came out (2.0.3 build 1148).

No longer blocking all network connections for many apps on launch for 1-2 minutes and launch is much faster now.

I wish It would have worked for me. My roon core keep crashing every 2-3 hours even with the latest build 2.0.3 1148)

Hey there, did you get any update from Roon about the crashes? I’m experiencing the same problems (exactly same crash and error .NET) unfortunately I can’t roll back to 1.8 because I’m using the latests Roon 2.0 build

No, I’ve not heard anything further on this issue since @Noris advised they were unable to replicate the error so far and requested Mac and Roon crash logs. If the situation applies to you, the Roon Server option suggested in his post may provide a fix. I’m unable to try it since I’m not willing to upgrade to 2.0 and change over to using Roon server without a rollback to 1.8 available.

Thank you. I don’t blame ya . I made the mistake and should have stayed on 1.8 Legacy.
Not sure if related but it appears that we are both using Netgear router ….

Don’t have a solution but reporting similar problem on iMAC (as core). Since the upgrade to Roon 2.0 it’s not useable. Multiple crashes a day, regardless if I’m playing music or not or if the Mac idle or not.
Painful

1 Like