Roon 2.0: From Rumors To Reality

How do you say that phonetically?

There is. They are conceptually different things. A time zone vs. a time standard. Look beyond the first hit in google :slight_smile:

But either way. In practice nobody cares.

Roon has not released a Roon ARC app for the iPad yet. The iPhone app works, to some degree.

A post was merged into an existing topic: Security with Roon ARC / Roon 2.0

This happened to me too, but only for a couple of seconds, then the next track appeared.

3 posts were merged into an existing topic: Security with Roon ARC / Roon 2.0

I’ve gotten this error once and another telling me there was an error with playback.

So it’s constant

I agree. I run my Roon Core on a QNAP TS-473 that needed a complete reformat in January thanks to some malware. I restricted access to my QNAP to the UK only, which will presumably block Roon Mobile were I to download it and use it outside of the UK (I am currently in Italy).

I will not be downloading 2.0 unless ARC can be disabled and access to my server protected. It contains a lot of other important business data besides Roon Core.

My music library is on an Innuos server that I do not use with Roon as the sound quality with Innuos Sense seems better. There was no mention of sound quality in the 2.0 note.


I am seriously impressed with what Roon has done here. While I realise I might be in a minority I was never interested in Roon Mobile being a remote streaming solution, I was only interested in being able to download all of my library to my phone and play the files locally. Although Roon ARC doesn’t really seem to explicitly address that I have, with the help of Brian and others from Roon, already been able to clarify a couple of things and work out how to use an “everything” playlist to get a single click download of my whole locally stored library to my phone, and with on the fly transcoding to 256kbs Opus as well.

There are two things that stop this 2.0 release from scoring a perfect 100% for me but even there both of the things I didn’t get are specifically mentioned in the Roon ARC FAQ as something being worked on so that’s good too.

My two missing features are…

1 - Roon ARC can’t control local endpoints. Not the end of the world but Roon says this will be added in the future and once it is then presumably I can delete Roon Remote from my iPhone and use Roon ARC both on the go and to control playback when I am at home (and not close to my iPad) which will be nice to have one less app taking up space on my home screen.

2 - No DSP support yet, in particular EQ and crossfade. The only thing that stopped me sending my AirPods Max back during the return period was the ability to use Roon DSP to EQ back in all the missing upper bass so they didn’t suck the life out of basslines and drum parts. But again, Roon says this will come in a future release and I use earbuds that don’t need EQ when I am out of the house so having EQ capabilities is really only a comfort blanket for me in case at some point in the future I buy new earbuds that I do want to EQ.

Congratulations Roon, you haven’t disappointed this user and I am feeling very happy about my lifetime membership purchase; money very well spent.


Is there a badge for this… :wink:

So that happened to me once, but in all my other tries the next track never came :pensive:
Maybe my core is too slow or something? I hope it fixes itself somehow.

Running the Core already opens a lot of ports, but only locally. If you do not enable port forwarding or upnp on your router, it won’t make any difference to run 2.0. Access is protected via your router and firewall, not by Roon Core.

I mean other DLNA server, other than Roon. But it’s not the point here. Again i made a mistake between UPnP Server and DLNA Server (answering too fast during a call :))

Ok. All is up and running. Set up port forwarding on the first router to the second and then from the second router to the Core (I wonder if your FAQ could be a bit clearer on this? Happy to help draft something.)

I’m seeing Roon ARC on iPhone but only if type the whole thing in. Doesn’t show if just type Roon

So: 2.0 has this new mobile app for remote access, which I probably won’t use (I don’t like port forwarding), and support for native Apple silicon (which I don’t use). That’s it? No new logo? I was hoping for something based on starfish!

1 Like

I’ve resorted to watching Pointless while I wait… could’ve listen to Steely Dan but hey - paint will dry

It’s no longer giving me the next track. I guess I was lucky the first time I tried this, but now it’s the same as you: Nothing playing, Go find something to play!