Roon 2.0 on ubnutu 20.4 or windows 10 pro

Roon Core Machine

I have two pc,roon serrver are installed on ubuntu 20.4 and windows 10 pro.
I Set port forwarding in my router edgemax er-x.
now my quuestion is :slight_smile:
roon arc is ok when roon server run on ubuntu;
roon arc can’t ready when server run on windows 10 pro,error code:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH 112.X.X.X:55000, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“112.X.X.X”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

please apologize my poor english.

how i need do in my windows 10 pro?i both use dynamic ip in windows and ubuntu.

Networking Gear & Setup Details

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

Welcome to the Roon community, @Sam_Lee1.

The port forwarding diagnostics you’ve provided suggest that UPnP is enabled on your network, but your router is refusing the connection. This is either the result of UPnP not being enabled properly on your router, or settings at the level of your internet service provider.

To confirm the issue is not with your local network setup:

  • Try to enable UPnP/NATPMP in the web administration interface for the router
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridgemode

If you continue to experience difficulties, we recommend reaching out to your internet service provider and passing along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

Thanks!

1、my route edgemax er-x was setted port frowarding,roon server run on ubuntu 24.0 in my pc ,roon arc is ok.

2、roon server run on windows 10 in my anather pc ,roon arc is not ready.
3、I enable windows 10 teredo TODAY +change my route edgemax er-x setting ,delete port frowarding setting,add upnp setting. now roon arc is ok.
4、NOW roon server run on ubuntu 24.0 OR windows 10 pro ,roon arc both ok.
ye!!!

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.