Roon 2.0 Says Not Compatible on ROCK [resolved: dns issue]

Roon ROCK fully updated, rebooted etc repeatedly says: Not Compatible.
NUC i7 with top levels of memory.
Remotes have updated without problem.
ROCK isn’t updating.

Hi Mihalis,

Can you provide support with the following information. Thank you!

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

First, thank you for taking the time to help me out. very much appreciated.

Operating System: Version 1.0 (build 227) stable
Roon Server Software: Version 1.8 (build 931) stable
Roon Database & Settings: 99% of 920 GB available
Internal Music Storage: 4000GB, SanDisk SDSSDH3, % of 3697 GB available

I made this server. it is a nuC, I believe i7 and has worked for 2+ years without other issues (only recurring issue is that sometimes Qobuz and Tidal need logging in again).

I connect this NUC to a USB interface into an MSB Select II DAC. As fas as I can tell, this connection is not involved in the problem.

The Network is a Virgin Hub 4 (in the UK). It is connected by ethernet into the NUC.

I don’t remember no of tracks but I have about 4tb of mostly high resolution audio. Please note that only 3% on that drive remains available. My library also includes many Tidal and Qobuz files which I stream.

When I got the email for Roon 2.0, I updated three remotes: iPhone 14 pro, iPad 12.9 pro and apple MacBook Pro. in all cases, I had to delete the remote and re-download it. when I then opened, without asking me to log in again, it “saw” the ROCK, updated fully the remotes (the screen shows a check next to it) and then tries to upgrade the ROCK. It will typically try for 20 or so seconds and eventually will tell me: Not Compatible, Try again. I tried to reboot, to restart, to re download the OS etc. I have tried about 20 times over 2 days.

I note that when it says Not Compatible, it also says “there was an error checking for an update”. I assume/hope that is where the issue lies. Does this mean there is an issue with Roon’s servers or with the way my system connects to them under this update (that is different from 1.8 since that worked fine.)

I have seen in some posts that some people talk about opening a port or something like that. This I assume is for ARC to work, which I am not even trying yet.

I will post the failure screen. Thank you again for any advice you may have.

all the best - Michael

I also know that my RSS is build 931 and that there is up to 1126. I have seen in some posts that people are stuck like me with the same build. However I have always updated when asked and there is no other way I know to update to any newer build. I don’t know if this is important.

Did you attempt rebooting? If not, try to hit “reinstall” on the web UI of ROCK.

I have rebooted, restarted manually, reinstalled the OS and used all three remotes separately in case it made any difference.

Reinstall ends up reinstalling 1.8???

A post was split to a new topic: Getting incompatible build message on imac

I am requesting some diagnostic logs from your ROCK – but it doesn’t seem to be responding… is it on?

I see your account doing stuff with our servers, but your ROCK is not responding to log requests. Anything unusual you may have done to restrict that box to/from the internet? or is it rebooting in a loop?

2 posts were merged into an existing topic: Roon 2.0 upgrade fail

Hello Danny

reinstalling the OS reinstalled what I had already as I believe it is the latest.

I don’t think I am on a loop. I restarted it this morning and it now shows running for 7h. I did once have loop issues but it was resolved and I have not had it since.

Should I look for something in my router specifications? what it is now is what it was yesterday when it worked fine with 1.8 but maybe 2.0 requires different settings?

Thank you for checking.

ok, so your ROCK machine comes up, talks to us for a second, and then stops.

I’ve helped many people today with variations on this matter, and all have been resolved by fixing up networking issues.

The last 2 were both related to DNS.

Let’s start by checking if you can get to the web ui for ROCK. I’d also check your DNS settings in your router and on your ROCK web ui.

if you can get those changed to, that would be a good start to fixing this up

Another thing to consider is that another user had configured their router to block all network traffic to their ROCK… I don’t think that’s your situation since your ROCK is connecting to us momentarily, but its always good to check you didn’t already do anything with your router and/or firewall.

Hi yes I am online trying that now. the traffic isn’t blocked but I read the fix and trying it. I will report back.

I’ll be here waiting…

That’s all she wrote. I changed to and I am now on 2.0. Thank you Danny.

Now will try ARC.

1 Like

I assume requires some specification change as it notifies me the Roon Core is not set up for contact outside my network. I read some people need to open a gateway or whatever its called?

if your router supports upnp port forwarding and the support is “on”, it should just work… go to roon → settings → roon arc

if not, you may need to turn it on.

if you don’t have that option or would rather forward the port manually, you can do so by following general instructions here:

the actual steps will differ based on your model of router, but it’s usually straightforward.

if you need additional assistance, I’m here for you.

Thank you, fixed. Wonderful.