Roon 2.0 update not downloaded to nucleus

roon nucleus software 1.8

Networking Gear & Setup Details

synology router

Connected Audio Devices

ps audio bridge
sonos legacy

Number of Tracks in Library


Description of Issue

downloaded roon 2 on my tablet but nucleus still only has 1.8 and it is stated as latest version. tablet with roon 2 will not communicate with nucleus. how to update nucleus? or if not able to update why are pushing the controller update.

Nucleus updated to 2.0 a couple of days ago and all was working fine until this afternoon I found it had shifted back to 1.8 - don’t know why. Now I can’t access it from updated remotes. Have tried reinstalling as per Help Center: RoonOS Core 2.0 (Nucleus / ROCK) but still stuck with Roon 1.8 Legacy.


I have the same problem and cannot find a way to update the Nucleus, I just go down a rabbit hole of support links to various ROON data that never gives me a fact to fix this problem.

1 Like

I have the same problem. Using Nucleus+.

1 Like

same problem here under nucleus. It wont update even from nucleus web

1 Like

Ditto, the 2.0 update was working for a while, and now the nucleus seems to have gone back to 1.8. I am using a Nucleus plus as my core. I can play Roon from my Mac.

1 Like

Pinging @support.


I have the same problem. I’m running Roon 2.0 on all my devices, but can’t update Roon from 1.8 to 2.0 on Nucleus. The solution described by owenhuu doesn’t work for me unfortunately.

I downloaded Roon Remote (Legacy) 4+## Control for legacy Roon 1.8, connected to nucleus, nucleus server can update to 2.0 again.
Proceed as follows:
1.downloaded Roon Remote (Legacy) 1.8.
2.connected to nucleus, the connection screen appears, like this: Connect button, then nucleus server update to 2.0 automatically.
4.Roon Remote (Legacy) 1.8 will not be able to connect nucleus server 2.0. Roon Remote 2.0, it will be able to connect nucleus server 2.0.
6.remeber, don’t click menu–>setting–>about, nucleus server will update to 1.8 automatically again!


Hi Lee_Mingfong, thanks for your tip! It certainly worked for me. I’m happy I can use my roon system again. Cheers

1 Like

I rebooted a couple of times again and now we’re all good. Phew!

I downloaded 1.8 remote yesterday and am now able to run Roon as 1.8, but nothing I do can get it to update again to 2.0.

Hi, Lee, could you please post a more detailed (step by step) procedure? I downloaded the Roon Remote Legacy on my Ipad and connected to my Nucleus core through Settings/Setup and then click “find” button in Find Roon OS. Clicked Nucleus ip address to get the Roon web interface. I clicked “Reinstall” button next to Operation System. However, it was still version 1.8 after updating and reinstalling. I am bot sure if I missed anything. I appreciate you help.

Thanks a lot Lee for the updated post. I did exactly the steps you l listed. However, once I clicked “connect” button next to my Nucleus core, my nucleus server didn’t update to 2.0. Instead, the Roon Remote (Legacy) connected to nucleus automatically. Some how the procedure doesn’t work for me. Not sure why that is.

For those having an issue with getting Roon 2.0 on your Nucleus please read the following link

1 Like

I read that you should “Close Out the Roon Server” before updating to 2.0 but I cannot find an explanation of HOW to “Close Out The Roon Server”. Can someone explain this phrase.

I have read these posts and note the understandable frustration of the various users. PLEASE can a simple solution be found so that the Roon App can be used to update the Nucleus core as in previous iterations? For those of us with impaired eyesight every screen activated adjustment is a needlessly painful struggle.

Hi @david_hoffman1 ,

Thanks for reaching out and for your patience here. I’ve looked over your account and I see that your Nucleus was running production1x.

I’ve just sent an update request to your Nucleus, can you please navigate to the Web UI and press the reinstall button?

For others in this situation, you can manually resolve this issue by following the migration procedure listed in our below article, or place your Roon Core online and we can try to send the update request (ROCK/Nucleus only).

RoonOS Core 2.0 (Nucleus / ROCK)

The names below in red are case-sensitive, capitalization matters

  1. Go to the /Data/ folder on your RoonOS Core (instructions) and create a new folder called branches

  2. Download the following file: roon_2-0 (It should be named roon_2-0 and saved with no file extension)

  3. Copy the file into the branches folder previously created

  4. Rename the file to roon (instructions on how to rename files: Windows / MacOS)

  5. In the Web Interface, click “Reinstall” under Operating System

When you are done, you should have a file called roon in the branches folder like so:

This topic was automatically closed after 45 days. New replies are no longer allowed.