Roon 2.0 update woes

Roon Core Machine Nucleus

15.6.1 i-Pad

Just downloaded Roon 2.0 and I am stuck in a loop that never brings up the main Roon window with the songs etc. Under Choose your Roon Core, it says update required and I press connect. The next window says “Time for an Upgrade, Install a new version of Roon to continue,” but also shows the Nucleus with 2.0 and says “you have the latest version installed.” Very disappointing. Roon has worked flawlessly for a long time, and now, nothing. Please send help!

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

1 Like

Did you update Roon on the remote?

I can’t update it because the main Room window where I would access Settings and update the Roon won’t come up. I’m stuck with the “Choose your Roon Core” and “Time for an upgrade” windows.

I had (and have) the same issue. I fixed it on my iPhone by deleting the app and re-installing but that hasn’t worked on my iPad.

If your remote is an IPAD you should check the app store for the updated version.

That did the trick. Thank you so much.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.