Roon 2.0 upgrade fail on ROCK -- stuck on build 923 [resolved: dns issues]

Roon Core Machine

Intel NUC 7i7 with Roon ROCK Version 1.0 (build 227) stable

Networking Gear & Setup Details

Unifi 1 gb wired

Connected Audio Devices

Bluesound devices, a Ropieee etc

Number of Tracks in Library

100 000+

Description of Issue

I had a message in my inbox yesterday evening CET+1 time about 2.0 and ARC. I clicked on the link on my iPhone and downloaded from AppStore. The app said my core was not found.

I went to the Roon app on my phone, it said that there was updates. I clicked yes, and it updated the app on my phone, but it couldnt upgrade the Core.

I went to my windows 10 laptop and tried upgrade from there. It upgraded the remote, but the core said it was an error checking for an update.

I have now deinstalled ARC and Roon app on my iPhone and deinstalled Roon on my win10 laptop and tried installing the legacy 1.8 on m laptop. Error checking for an upgrade. What to do?

@Staffan_Jonson your ROCK is running a build that was released back in March, and there have been 13 newer builds released since then.

What you can try is to go to the Web Administration page and reinstall the operating system. This, I believe, will install a recent build for you.

1 Like

I reinstalled the Rock OS, it told me it was reinstalling and ugrading, and that it succeeded. It still tells me that I have Version 1.0 (build 227) stable installed

That’s correct, that is the latest build of the OS. I’m talking about the build of Roon - which is 923 in your screenshot; dating from last March.

I thought that one was upgrading everytime I have this “There is upgrades. Upgrade on all devices” procedure. How do I upgrade that?

Well, it should have been upgrading if you clicked the “Upgrade all” button. Odd. Let’s see what someone from the Support team has to say…

Does anyone know if there is a way to upgrade Roon Server Version 1.8 (build 923) stable on a ROCK OS to the latest (1126?) other then from a remote client? Mine seems to have got stuck on 923 although I have done “Upgrade All Devices” many times. Tried Putty but it wouldnt let me in.

Just to give an update on this crap. Since Roon apparently not is going to rollback this half baked update I tried to follow the instructions on to see if my RoonOS/Roon Server would take an update with the method of adding the roon 1.8 legacy in a branches folder. It wouldnt. I still have OS Version 1.0 (build 227) stable and Version 1.8 (build 923) stable there after 3 reinstall tries and some reboots.

oh wait, you already did that here :slight_smile:

You may check on mine to if you want Danny. Its up and running Version 1.0 (build 227) stable and Version 1.8 (build 923) stable

I’ve asked it for logs, and it’s not responding.

maybe DNS issues? or some other connectivity issue?

what does “reinstall” button say/do when you click it on the web ui? if you tried in the past, try again.

It says “Reinstalling latest software. This can take some time to download and install. Please wait until it is complete.” while in process and “Successfully reinstalled system.” after. Still on Version 1.8 (build 923) stable though. Pings fine and answers to Web GUI commands.

Ok, i cant get logs so i cant see why its failing… can you pkg them up for me?

Sure if you tell me how. RAATServer/Logs?

looks like you know what you are doing… you want the RoonServer/Logs folder

How do I send them? Its 21 files

ill pm you

talk to me about your DNS…

this is from your logs:

09/22 13:35:33 Error: [appupdater] While downloading update: System.Net.WebException: Name or service not known (

your machine cant download the build because it cant resolve this DNS… check your DNS settings and maybe just give the box a reboot and hopefully it’ll work next you hit reinstall?

OK! I changed DNS to (had local DNS before) rebooted and updated to Version 1.8 (build 1126) production1x.

Ok, so now I need to figure out how to go to 2.0?

Download roon_2-0, replace the file roon in branches folder and reinstall?