Roon 2.x Upgrade - Failure to Initialize Audio Device Problems

Roon Core Machine

Roon Nucleus Plus

Networking Gear & Setup Details

Roon Core and Roon endpoint (a 2019 Mac Pro running Ventura 13.1) connected via cat 6 Ethernet and are connected on same Ubiquiti 8 port switch.

Connected Audio Devices

Mac Pro connected to Project Audio’s S2 Digital preamp via AudioQuest USB cable. S2 device is configured in Roon as remote (endpoint). S2 is configured as private zone, exclusive mode Yes

Number of Tracks in Library

15,601 tracks on internal SSD in Nucleus Plus

Description of Issue

I’ve been using this set up with Roon since 2020 - pretty stable. Since upgrading to 2.0 (currently running build 1193 on core and endpoint) I’m getting sluggish overall behaviour when launching MacOS or iOS, or iPad OS clients. More importantly, on the Mac Pro specifically since upgrading to 1193 a few days ago I’m getting failure to initialize errors. If I disable the S2 device and re-enable (or reboot), playback will start but if I leave the Mac idle for some time and then try to play music again with Roon client still open, I’ll get the same errors of failure to initialize audio device, etc. This is/was just a bit intermittent when I upgrade to earlier builds of 2.x but now it’s constant since upgrading to 1193.

Just to add a bit more info. I was just playing an album (streaming from Tidal) and tried to switch to a different album (Tidal or local) and I got the same error of failure to initialize. I waited about 60 sec and hit play again and this time it started playing. So the issue isn’t some kind of device timeout I’d guess since I was in the midst of listening to something when I got the issue trying to switch to something else.

Hey @Stuart_McFarlane,

I’m sorry to hear you’re running into issues after updating your core to 2.0.

I’m seeing a fair amount of network errors tied to your core, I’d be curious to see how things function when you hardwire your Nucleus directly to your router, bypassing the 8 port switch.

With that, can you also share a time stamp (date,time) the next time you run into a failure, and share that info here?

I’ll be on standby for your reply :+1:

Hi, thank you for your response. Moving the Nucleus is not practical. I appreciate troubleshooting is a complicated affair but I maintain that there’s likely nothing wrong with my network which is all Ubiquiti. The issue I raise is specific to one endpoint only. All my other endpoints are on the same network and some on the same 8 port switch are all functioning fine. The difference between them is the MacPro has a USB audio device attached. I speculate there’s a timing or communication issue with USB devices that Roon desktop seems particularly sensitive to that is causing the errors I’ve experienced. I’ve seen a fair number of people in this community describing similar issues to mine and the commonality seems to be USB devices like DACs, etc. in the setups.
I’ve currently worked around the issue by turning off exclusive mode. As soon as I turned it off all the issues with the MacPro and the Project Audio USB pre-amp disappeared.
Regarding the “errors” you’re seeing I wonder if they are actually a feature of my Pihole server blocking unwanted traffic?