Roon access continuously my QNAP 451A

Hi Guys,

I have a QNAP 451A with 4 hard disks of 10 To each, 4 Go of RAM on the QNAP and a Microsoft Surface PRO 3. Before yesterday, i used The Roon server and the Remote both on my Surface. Today, i installed the Roon Server on my Qnap and the Roon’s database on a SSD hardisk (1 To) plug on my Qnap on USB 3.1.

The roon server has been accessing the hard disks continuously for more than 5 hours without stopping and the hard disks make a very annoying noise.

In addition, the Roon remote keeps disconnecting from the Roon Server every 2 minutes and after the Roon Server starts again accessing continuously the hard disks.

Do you have a solution or did I make a wrong settings ?

I have always coonection lost evry 2 mintues, you can see the pictures.

Thank you to you.


Roon Server does an initial scan of the music library, which can take a while to complete. This depends mostly on the size of your music library and the processing speed of the core (=your QNAP NAS).
Could it be that QNAP is still analyzing? You can see if this process is running on a Roon Remote device. There should be a spinning circle:

This task is quite cpu intense. You can check if the situations gets better by turning off music analysis in the settings. See the knowledge base for info about this.

Hi Christopher,

Thanks foir these informations but i knew them.

When the analysis is finished, my hard disks continue to work because Roon server or/and Roon remote doing something.

Why when i launch Roon server i have linux 4.2.8 instead of Windows 10 as my Surface is on WIndows 10 ?

And why the Roon core always disconnected each 2 minutes ?

My surface is connected in ethernet not in wifi.

If you are referring to the Linux 4.2.8 string as shown in your Screenshot: This is an Information about your Roon Core system on your qnap, which is apparently using a Linux 4.2.8 kernel.

I can‘t say for sure why there is a disconnect every 2 minutes. Can you send me a zip archive of your Roon logs from the qnap core?
You can get these by clicking the ambulance icon in the Roon web user interface (which can be opened in the QNAP administration panel).
I‘ll send my email in a private message…

Can i change the operating system of the Roon Core ? Can i try anonther one ?
The logs files are on the way.
When i stop the Roon server, the hards disks are stopped too…
Thanks Christopher.

Thanks for the logs.

The operating system of the Roon core depends on the device the core is running on.
On NAS, this is in most cases a linux system. If your core is running on a windows computer, it will be a windows system, on a Mac it’s a Mac system… The system on a NAS is not meant to be changed.

Regarding the spinning disks and disconnect issue: I have an assumption, but would like to verify it with a screen shot of your storage locations in your Roon settings.
Could you also provide one like the one below (which I have taken from my system)?

Hi Christopher,
This is the screen shot.

Many thanks.


Hi Wilfrid,

The screen shot was taken, while you were connected to your QNAP core, right?
(I was wondering because of the first storage entry which is deactivated: ‘Music Folder’. This one does normally not show up on the NAS, at least when starting from scratch (did you migrate the database from a previous system?).

You should not use a network share here. It might seem logical to add folders on a NAS as a network share (because it is a network storage device). But this is only true, if the files were accessed by a different device in the network.
In your case, the Roon Core is running on the QNAP NAS and the music files are stored on the same device. In this case, these should be added as a local folder.
Try to edit your storage locations (press the 3 dots icons on the right side of each storage location in the Roon Storage settings):

My guess is, that the QNAP core is checking changes in the filesystem continuously, which is causing high bandwidth in the network connections, which result in a connection loss of the remote device (=your Surface tablet). This would also cause the HDD activity…

Yes, i taken the screen while connected to my core.

It’s strange because i don’t see my qnap NAS like you. I can only add a network share.

It seems, your core is running on your Surface tablet as well.
Can you go to Settings -> General and click the ‘Disconnect’ button and check if you can pick your QNAP as a core?

You should also see there, which device is currently acting as your core:

My core is now on my qnap :

i Choose Connect but after somes minutes Ronn said to me that it lost the Core Connection and i’m not in WIFI, only in ethernet.

Are these disconnections logged ?

Can you check the storage settings and post a screenshot of it again. It should look different now when connected to the QNAP.

Hard disks continue to work harder and harder, it’s unbelievable. My surface is off and the remote too, only the core is runnong and it still analasing i don’t know why …

OK. This look fine! :+1:

Do you notice hdd access on the QNAP, when Roon on the surface tablet is shut down?

yes, my surface is off and the qnap is always working like on a server room !!!

when i stop the core, the qnap stop too

You are aware that your track-count is 265K tracks? That will definently take some time analyzing, like a couple of weeks or so.
And your selected QNAP is not exactly the quickest dog in the race so you’ll just have to be patient. (dual core Celeron 1.6 is way low on the performance scale)
I’m sure it’ll do fine when done, but you will have to be patient while it does its analyzing and cataloguing…

Yes i know loooool
Witch nas do you recommend ?
Can i install the Core on a pc instead of a nas ?
Thanks again

YES!!! You should do so immediately.

Mickael, the problem is not the first analyse, the priblem is that the core always analysing after the first one.

Hi John,
I don’t remember the first time i instaled Roon, i could choose where i wanted to instal the Core.
How i can do this ?