Roon + Airplay2 + Cambridge CXN: a few issues

Roon Core Machine

Macbook Air 2021, 1,6Ghz i5, 16 gb RAM. Running on Catalina.

Networking Gear & Setup Details

Wifi no VPN.

Connected Audio Devices

Remote Roon goes to Cambridge CXN (V1) through Airplay 2.

Number of Tracks in Library

23 000 tracks.

Description of Issue

Here are the two issues I have with Roon. The first one is recent, the second one never solved.

  1. Recent issue (since 6 months or so): I have to press “Play” twice in Roon whenever I fire up a song after I have booted my streamer (Cambridge CXN). I remember this problem was present after a Roon update, not after a CXN update. Does anyone know anything about how to solve this? Not a big one, but it would be nice to have it solved.

  2. Permanent issue: Whenever I stop and start a new song, there’s a near 2 seconds delay before hearing the music. I am sure this has to do with Roon, since I was an Audirvana user before and the delay was almost non existent. Not a biggie, but would be nice to minimize the delay.

There you go, keep up the good work.


why do you use airplay 2 to begin with? WiFi via Roon RAAT probably serves you better.


Since when is Roon RAAT an option for the CXN (V1)?

Right, forgot about that. Only had the V2 a few years ago.

Hi @Martin_Blanchard1 ,

What is the model/manufacturer of your networking gear? Is the Cambridge plugged in via Ethernet?

Can you please confirm if the same issue happens when you try to use the Cambridge USB connection? I believe the USB connection will also get you higher sample rates, in case you would ever want to add a Roon Bridge to the equation.

1 Like

Cambridge is plugged in via Ethernet, the modem/router is a Hitron Coda-4680.

I will have to find a USB cable, not sure where I have one, and my computer is USB-C. It may take a while. I do not wish to use the USB connection in any case.

Is your core connected via ethernet? If not, it should be for optimum performance. Also suggest changing the DNS settings in your router from whatever your ISP uses to Cloudflare -

Sorry, I was not very specific in describing my equipment.

My Core is a MacBookPro always on, connected via Ethernet. My streamer is also connected via Ethernet. The Core wifi is off, so Core and streamer talk over Ethernet. My remote controlling the Core is connected via wi-fi.

I already made the DNS change a long while ago.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.