Roon + Allo USBridge stopped working after DietPi Update

Hello @support and Last week, I updated my USBridge to DietPi v6.22.3. I haven’t been able to get audio out of my system since. I’ve done similar DietPi updates in the past, with no problems, so I’m a bit stumped.

Core Machine (Operating system/System info/Roon build number)

OS Version 1.0 (build 174). I’m not sure how to get the system info from Terminal, but it’s a NUC i5 model that is definitely up to spec. Server Version 1.6 (build 416).

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connection to a network hub by stereo. I’ve check/restarted everything and can confirm this isn’t a network issue (Roon sees the USBridge).

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

i5 Core > Ethernet > Allo USBridge > Peachtree USB into DAC (integrated digital amp)

Description Of Issue

I check my Roon and Allo dashboards from time to time, and last week Allo showed an update for DietPi. I’ve done this before and proceeded to complete the update process. Here’s a screenshot of those settings.

After the update, I wasn’t getting any sound out of the system. Roon appeared to be receiving a signal, but no audio was heard. I played will all the setting to no avail.


The Peachtree DAC only support USB1 and as I’ve said, it’s worked flawlessly until this update. I’m not sure if something in dietpi has caused an issue or whether the issue is with the USBridge or a Roon setting.

Thanks you!

Hi @Michael_Beveridge,

Can you try another USB port on the Allo USB bridge to see if that helps?
Does the Peachtree USB DAC work when connected directly to the Core bypassing the USBridge?
What if you connect another USB zone to the USBridge, does that work?

– Noris


I am running the Allo Usbbridge on v6.22.3 with my Qutest dac. I’ve had an issue in the past where the upgrade(or some other event) muted my DAC’s sound output. I am not sure if it can be fixed in the Web UI, but if you ssh to the usbbridge, you can run: “alsamixer”, then hit F6 to select your DAC. Make sure you don’t have an “MM” for mute on any of the bars. You can move to the channel with the arrow keys, then hit “m” on the keyboard to unmute.

Shot in the dark, but maybe it will help.


I ultimately got things working again. I noticed that my USB connection probably wasn’t working from the screen below. After dicking around for several days, my “fix” was to set the soundcard to USB-DAC (removing the 1.1 option). I’d done this earlier, so am not sure what else changed, but I did do a lot of snooping in the dietpi settings, so maybe that helped too. Who knows!?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.