"Roon: An audio file is loading slowly. This may indicate a hardware or performance problem."

I have been having this problem for months now and I have searched the support posts and have found some that talk about this issue but no resolution on any.
I am using a MAC Pro 3.5 ghz 6 core as my Core with my music stored on a Drobo (10TB/6.85 used). There are no issues when playing Roon from the Core.
When I attempt to play Roon in my HT Room I encounter this error 95% of the time.
I was playing Roon through a MAC Mini which had this issue and recently moved to an OPPO UDP-203 and still have the problem. The OPPO is hardwired to my network which is a high speed Gigabit service.
I have been a Roon user for a few years an only began having this issue about 8 months ago and I have actually moved to a new place 4 months ago and the problem has followed me. I am not experiencing network issues with my DVR or AppleTV (4k).
Last night I trashed and reinstalled Roon on my Core as well as doing the same in my iPad which I use to access Roon in the HT Room through the OPPO - still have the problem.
Feeling very frustrated at this point…any ideas?

How is the Drobo hooked up? Any way to check it’s network speed?

oh, and adding @support so they get notified.

Can you describe your network in detail, including the brand and model of all routers and switches.

I seem to have had a breakthrough on solving this problem. When Roon Build 1.3 was introduced my library which is stored in iTunes as ALAC files appears to have had something happen to it. It was only listed as a iTunes library of Build 1.2. I have re-added my entire library directed to the Drobo and it seems to have fixed this issue. The metadata is a bit of a mess right now but let’s see…
Thanks for the responses guys!


Hi @Wayne_Carter ---- Thank you for the post and sharing your feedback with us. The insight is always appreciated!

I wanted to check in with you on the above since making the mentioned adjustment. Please let me know how things are going and if further assistance is required I will be glad to lend a hand.


Hi Eric,
So far so good, this “discovery” seems to have solved my problem. I have had some weird things happen with a select group of titles that have gone into Roon duplicated which I can’t quite figure out why and not sure how to fix them. I tried deleting “one” of the duplicate files but it deleted the file completely.
Also I have lost all my personal library edits I have done to the software over the last 2 years which really sucks…

Hi @Wayne_Carter ---- Thank you for the follow up! Very appreciated!

Continuing forward, I am wondering if the duplicates you are seeing has anything to do with the “fix” here. I have seen a similar behavior occur when a musical collection is moved from a previous storage location to a new one. Can you provide some insight into the steps you took when doing away with the previously used iTunes integration (i.e 1.2) and making the Drobo the new storage location?

What does the library cleanup window look like? A screenshot would be greatly appreciated!


What is odd on this is I have never changed the storage location in all the time I have been using Roon. This just seemed to happen somewhere along the line after the introduction of 1.3. I have looked at the Storage tab a dozen times before and never even thought about it that it was not linked to my Drobo storage any longer and was listed as “iTunes Libraries Roon 1.2 and older”.
As I have continued to add new titles to my library over these last months they showed up in my Roon software they just continued to not play properly but still played sometimes. I would be good for a few albums but once I started to move around inside the library it would begin the error.

To attempt to fix the problem I just disabled the iTunes Library that was under that name and set up a new folder directing Roon to my iTunes library on the Drobo. It re-added my entire library (169,370) tracks but oddly a handful had duplicates, at least I think it is a handful… In some instances the entire album duplicated and others only certain tracks.
An awesome feature in future might be a duplicate “find” function although when I attempted to delete what I thought was one of the duplicates I actually lost the file completely.

Not sure this is much help…lol

The good news is I have been using Roon since this and no longer have the “Roon: An audio file is loading slowly. This may indicate a hardware or performance issue” hang up.

Thank you for touching base and providing me with the requested feedback @Wayne_Carter, very appreciated!

I just wanted to be certain that the mentioned duplicates where not occurring dude to change in storage location :microscope::innocent:

“An awesome feature in future might be a duplicate “find” function although when I attempted to delete what I thought was one of the duplicates I actually lost the file completely.”

If you go to the “album” browser, click “focus”, and then “inspector”, there will be an option listed to focus on “duplicates”.


A post was split to a new topic: “An audio file is loading slowly” for DSD64/DSD128