Roon: An Audio file is loading slowly. This may indicate a performance or hardware problem

Hello support team,

I am using Macbook Pro ( OSX10.11.6 3.1GHz i7 8GB DDR3) The last version of Roon (1.2(build 165) stable(64bit)

Setup: NAS(SynologyDS 213)>Router>Mac Pro>Roon>System output.

Every time when I play the music from the NAS, it always shows ROON: An Audio file is loading slowly. This may indicate a performance or hardware problem. whatever my formats are.( PCM、DSD、DSD*2).

Setup: Mac Pro>Roon>System output

When I play the music from my Mac or a hard drive, It is working fine.

Please let me know how to solve this as soon as possible.

Thank you

Make a new watched folder on your mac.
Put a CD that is loading slow, in that folder.
Try again.
Faster? I think the NAS/network is slow.
When you connect a harddisk to the mac it is better.

Hi @Jim_Lo ----- Thank you for the report and my apologies for the troubles here. Based on the observation you have made in regard to local content not exhibiting the same behavior as the content located on your NAS, my gut feeling is that there is some sort of bottle neck occurring across your network.

May I kindly ask you for the following information:

  1. A description of your network configuration / topology as well as insight into any networking hardware you may be implementing (routers, switches, repeaters, extenders, etc). Knowing the make and model of these devices would also be helpful :sunglasses: I want to understand the exact chain of communication between your devices.

  2. In regard to this issue you are experiencing, have you noticed this behavior with all of your media or are there specific codecs/sample rates you notice this more frequently with?

-Eric

Hi @Eric Eric,

(1) I am using ASUS RT-AC1200 as my Router and no Switches、repeaters or extenders. And using one Internet cable from the Router to the NAS and then my MAC PRO got the same wifi to import the folders from my NAS.

(2)If I play the NAS folders from the APP of my audio system without ROON, it is working fine and no problem. But as long as I use NAS with Roon, the information would show “Roon: An Audio file is loading slowly. This may indicate a performance or hardware problem”. Every sample rate has the same result.

make sure you have jumbo frames off on the NAS that is a known issue

wifi will often have issues too…see if it happens with a wired LAN connection to the mac.

you should also check that the NAS is using SMB-3 under advanced settings button in windows file sharing panel

2 Likes

Ah, wifi.
Try to use it only for remote control (iPad enz)

HI @Jim_Lo ----- Thank you for the follow up and taking the time to answer my questions. Moving forward, the suggestions made by @Paul_Chatfield (:+1:) are sound.

I would highly suggest checking that jumbo frames are disengaged on the NAS as well as verifying that the unit is is using SMB-3.

Lastly, removing WiFi from the equation and using a wired LAN connection to the MAC will help us confirm if there are issues going on with Roon communicating with the NAS across your network.

I look forward to hearing your observations!

-Eric