Roon and HQPlayer integration issues (Solved)

Hi all, I’m hoping someone can help me. I’m having issues getting Roon to play DSD256 with HQPlayer. I use a Mytek Brooklyn which can do DSD256 natively. When I open Roon and have HQPlayer open at the same time, Roon does not recognize it, even though I have set it up in Roon to play DSD natively and I can see that DSD256 is one of the “Green” options in the Roon audio settings. When I shut HQPlayer down and reopen Roon, all of the conversion options are again available. I can play any file type through HQPlayer and upconvert to DSD256 (44.1 - 384000, DXD352.8, DSD64 - DSD256). Is there some setting in Roon that I need to enable/disable to get it to work with HQPlayer?

Hi James, did you put HQP in network mode (globe icon) and then attach HQP as a network source in the Roon Audio tab? If HQP and Roon are on the same machine, choose localhost when selecting HQP as a source.

This KB setup guide sets out what to do. After the HQP zone is selected for output in Roon you will need to select SDM(DSD) in the far right drop down menu on the HQP front screen in order to output DSD.

Hi Ruud, thank you for the response. Yes, HQP is in network mode. I also checked the box to add HQP as a network device when I first set up Roon. Localhost is checked as it is on the same machine as Roon.

Hi Andy SDM is checked as well. My settings are:
My current settings:
Channels: 2
Channel Offset: 0
SDM Pack: None
Buffer Time: 250ms
DAC Bits: 32
AltDSD: Unchecked
PCM Default: poly-sinc-shrt-mp
SDM Default: poly-sinc-shrt-mp
Dither: Gauss1
Modulator: DSD7
Sample Rate: 384000
Bit Rate: 11289600
Vol Min: -60dB
Vol Max: -3dB
Cuda Offload
Pipeline SDM

It’s the output menu on the front screen that I’m referring to, just under the volume control:

In HQP, did you set DSDIFF/DSF settings (under File menu) DirectSDM to “on” so that it stays on?

I am not fully sure on this one but try: If you have SDM on by default, shouldn’t you choose “none” for PCM filter and switch SDM Pack to DoP? That should upsample everything to DSD except native DSD, which is passed through unchanged because of the DirectSDM setting.

Hi Andy, that is what I am using. SDM is checked.

1 Like

James under Roon settings-Audio in the middle of this box you will see HQ player, is the output associated with HQP listed as the current output in Roon? If not then the audio will not go thru HQP.

What processor does your PC have? You are selecting a filter with a lot of CPU processing and it could be possible your CPU is not up to it. Any i7 4th gen or above is fine and probably any i5 6th gen would be okay as well.

If you want to upsamaple all music to DSD 256 under DSDIFF/DSF settings do not check Direct SDM. If you check it then all DSD files will play natively rather than being up sampled.

Your settings look fine, possibly try a 2S filter of what you list above and do what Andy says make sure on the main HQP screen SDM is listed (Under the round volume knob).

I don’t know what you are talking about the DSD settings in roon I don’t see any of that when I set up roon to output thru HQP. Makes me think you have the wrong output zone selected in roon.

Hi Ruud, DSDIFF/DSF is set to stay on. My Brooklyn DAC will not output DSD256 over DoP, so I leave that unchecked. I am playing a DSD64 file upconverted to DSD256 through HQP right now with no issues. It seems that this issue lies somewhere with Roon. I’m sure that I have everything set up to output DSD256 through Roon. If I open Roon with HQP open and check the Brooklyn audio settings, Roon will automatically turn the DSD256 option red. If I close HQP and recheck the Brooklyn audio settings in Roon, DSD256 is re-enabled.

Hi Quadman, thanks for the response. I have enabled HQP in Roon and it is set up as one of my zones. I have attached some images of what is going on. Another issue I just found with Roon is that I’m currently playing DSD256 (upconverted from DSD64) through HQP and when I open Roon, my DAC disappeared.
My computer has an i7Quad Core processor and 32GB if RAM so I hope that is enough to do whatever it is that Roon/HQP need to do to play DSD256. I have also attached another screenshot of my Brooklyn DAC disappearing from audio devices in Roon when I have HQP open.

Hi James, although I see that Roon can not find your Mytec, Roon and HQP can not both access the Mytec. They both try to claim exclusivity. Try completely disabling Roon access to the Mytec. Signal should go from Roon to HQP and from HQP exclusively to the Mytec.


You can’t have Roon and HQP enabled at the same time to use the ASIO Mytek Driver as both will conflict over exclusivity.

If you want to use HQPlayer and Roon:

In Roon, disable the System Output and the Mytek USB Audio. All you need is the HQPlayer zone which Roon will just forward the direct data stream towards. In HQPlayer setup the features you want; making sure it has been network enabled. In this setup, Roon is doing nothing but forwarding the data stream, it does no processing that is all in HQPlayer

1 Like

James, Daniel is correct- in my set up I disable all zones and the only one I have enabled is HQ Player because that is all I want to output. Then on the main roon screen in the lower right side make sure the output zone is HQ Player. It should work. Drivers do not like to share they are selfish.

Your i7 CPU is enough to handle DSD256 if you get any stuttering of the music playback then try the 2s family of filters in HQP.

Awesome response. I had not considered that.

I just changed those settings and it’s working like a charm. That’s what I love about this community. Thank you.

1 Like

Hi Quadman, I changed the Roon settings and everything is working like it should. Thank you for the quick response and for helping me to get this working properly.

your welcome, this community has saved my butt more that once. Finally you had a topic I knew something about. Now you need to figure out a way to get DSD512 and the dac may not be able to do it, or the dac’s driver may be the limiting factor. DSD512 is where the magic happens.

1 Like

DSD512 may be a bit of a challenge :slight_smile: From what I understand from the Computer Audiophile DAC forum is that Mytek is working on a firmware upgrade for the Brooklyn that will allow for DSD512. We will see… for now I am happy that I have the current issue resolved.

1 Like