Roon and iOS and Airplay not working [Solved: changing internet connection properties to ‘private’ network]

Core Machine
PC, Windows 10 Pro, 32gb RAM (it’s a new and powerful machine)

Network Details


Audio Devices

Muso x2, Muso QB x 2, and Sonos Move x 2

Library Size

Description of Issue

Nothing has changed in my set up but one day last week it randomly stopped working. Please help!

When I go to my PC (also my core) and I can play via the Musos and Muso QBs (set up together in a group of 4) but not via Airplay. Plus my iPhone and iPads just won’t connect to the Core. I changed nothing but one day it wouldn’t work.

Any ideas please?
I’ve tried restarting the BT Hub and the PC Core but nothing gets it working again.

Should I just uninstall Roon on my PC (core) and start again?

No not yet

Did it coincide with a Windows update ?

Try installing the video driver for your specific video card , download from the manufacturer’s site. Reboot everything , modem router the lot . See if that helps. The Windows generic drivers can sometimes cause issues.

Thanks @Mike_O_Neill, it might have done but am not sure. Is this common after a Windows update for Airplay no longer to work and/or the Roon remotes on the iOS devices no longer to be able to connect?

I’ve checked and the video drive is the specific one for the NVIDIA GeForce card and is made by the manufacturer not Windows generic.

Anything else I should try?

Have you restarted everything ?

Try unplugging everything from the mains, including your network gear, wait a few minutes then restart each component in turn. Wait until each component has fully started before starting the next one . This sounds like a network issue are you Ethernet where you can ?

Have tried restarting everything and turning on/off again. I’m not able to be Ethernet in this property. But, it has all been working fine since last summer with this exact same setup - haven’t changed anything but suddenly it has stopped working.
I can play and control the Sonos Moves via the Sonos app.
I can control and play the Naim Musos and Muso QBs via the Naim app and as a group via Roon when I operate it via my PC (my core).
What I can’t do is make any speaker play via Airplay in Roon and I can’t connect any iOS device Roon remote (iPhone and both iPads just time out).
I haven’t changed any hardware and haven’t changed any settings on the BT hub router. @Mike_O_Neill any other ideas? Reinstall Roon? Can anyone from Roon help? @Roon_Superuser anyone?

Or @support can you help? Just realised I should tag you in.

Try turning off any firewalls etc that could be blocking connections internally

There are no firewalls on. As said, nothing has changed from when it was working before. But also if it was a strange inadvertent firewall issue, surely that wouldn’t allow me to play what I can in way can via the Core (see my previous post)?

Will depend…windows loves to mess with stuff when you dont want it to - updates especially notorious for this.

Make sure everything is on the same subnet address ranges too and also not inadvertently got on a guest network

Thanks for this tip. I’ve gone back and checked and all appear to be on the same subnet address ranges and within the expected range of IP addresses. The hub is dual band - does it matter to Roon if the devices are split between the 5ghz and 2.4ghz bands? They all appear to be on the 5ghz but that was only other thing I could think of.

@support is there anything else you can help with here?

As long as the IP’s are in the same range its fine…LAN 2.4GHz 5Gz roon wont care.

1 Like

Hey @Duncan_M-S,

I am so sorry to hear that all of a sudden Roon stopped working for you. It’s definitely not what we had hoped it happen. Thanks for letting us know and for engaging on the community.

I’ve checked and the video drive is the specific one for the NVIDIA GeForce card and is made by the manufacturer not Windows generic.

Thanks for checking on the drivers. However, I was hoping that, just as @Mike_O_Neill mentioned, you could:

  • uninstall the drivers
  • navigate to NVIDIA’s website and directly download them
  • install the drivers
  • restart your PC
  • try to open Roon

Windows’ automatic updates are many times unreliable, especially when it comes to graphics drivers.

Thanks in advance :pray:

Many thanks @beka more than happy to try that but just to check, would that make any difference where Roon itself is working on my PC (my core) and I can play in certain ways from the PC but it is just AirPlay that isn’t working and connecting iOS devices Roon remotes that won’t connect?

Great question, @Duncan_M-S. Yes, having your graphics drivers installed correctly should help roon Run on your PC.

As far as your iPhone and iPads not connecting to the Core, are all your Roon devices running the latest version of Roon?

Also, if you navigate in Roon to Settings → Services, no Airplay devices are listed? If they are, can you enable them?

@beka All the iOS devices are updated to the latest version of the Roon app. All the AirPlay devices are enabled in Roon on my core (as per they were before and all were working fine). This must be a Roon problem because I can find and play all the Naim devices via the native iphone Naim app; I can find and play the Sonos devices via the native iphone Sonos app; I can play via AirPlay directly from my iPhone to any of my Naim and Sonos AirPlay devices on my network; and I can play from my Roon PC (core) to my Naim devices (as a group and invidually).

The issues I have are that (i) Roon cannot play my AirPlay group (or any individual AirPlay device) via my PC (core) and (ii) that my iOS devices cannot connect to my Roon core. As said, it was all working fine and then one day just stopped. What is going on?

Is uninstalling and reinstalling Roon on my PC (core) a bad idea and/or likely to solve the issue?

Please help resolve this because I have paid for lifetime Roon but this makes it all but unusable if I can’t control it with my phone or iPads.

EDIT: I have also just tried deleting the iphone app, turning phone off and on again, reinstalling the app. Obviously set the Roon app to allow it to find network devices but still it cannot find my Roon core.

can you try an app like FING on the phone to see if it can see your core machine on the network…this still sounds like a firewall issue (perhaps antivirus too) or if your network is different between the core and iOS devices… also make sure you are not on a guest network as this will not allow local connections but internet will be OK

Thanks for the tip. Just tried FING and it can see my core machine on the network. Tried ‘pinging’ it via the FING app but not sure what the right result should look like?

I don’t have any guest network - I only have the single network I connect to. The guest BT networks I deliberately don’t connect to because of the Roon issue. Have double checked and that is still the case.

And the address range is the same for the Core PC? maybe you can list the different remotes and PC addresses or at least the last 2 digits ie yy.xx

A ping response will look something like this

PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=128 time=0.361 ms
64 bytes from icmp_seq=1 ttl=128 time=0.525 ms
64 bytes from icmp_seq=2 ttl=128 time=0.280 ms
64 bytes from icmp_seq=3 ttl=128 time=0.670 ms
64 bytes from icmp_seq=4 ttl=128 time=0.389 ms

Yes, the address ranges all seem to be fine and within the expected range for the BT Hub.

When I do a ping of the PC’s IP on FING it just returns a load of red vertical lines with a small red ‘x’ at the top. Is that a clue as to what’s wrong?