Roon and jplayfetmo

Core Machine (Operating system/System info/Roon build number)
PC Win 10 last update.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
My audio card is an 16/44.1 Art Legato
Naim DAC
I use jpleyfetmo

Description Of Issue
Hi i’m new here (trial version) i have a question, first of all I’m not able to fill all fields you need an we apologise for that.

If I heard my FLAC music from my hda 16/44.1 no problems at all even with Qobuz 16/44.1 files no problems.

Problems start with hires, I try to force 32 bit to 16, via jplay, but I don’t have 44.1 only 48KHz so, I don’t know why (cause for example with the same hardware I can play hires directly from Qobuz in my PC routed I’m my hifi with no modification at all.

Can you pls explain?
Tks Giovanni.

Hi @giovanni_brunetti,

If the issue occurs when using the Roon app without Jplay involved, then we can assist, but if the issues only occur when using Jplay + Roon, I would reach out to the Jplay support team for further assistance.

Hi,tks for the answer, but jplay support said the same think ,contact Roon support cause jplay support all frequencies from 44.1 and 48 and all its multiple.
So I’m able to play files 16/44.1 with Roon via jpleyfetmo even on my usb hda or via qobuz and I can see in Roon config that jplay is part of the process and all was fine.
Listen to 24/96 hda or qobuz no way with Roon to resample to 16/44.1 that’s my artlegato limit ,so I can’t play those files only with art legato output vs jpleyfetmo:
Artlegato does downsampling.
With the same all hardware and software (not Roon involved) all works fine and jplay to ,for example playing qobuz directly jpleyfetmo works finev6in 24/96 and more.
So it’s a Roon problem I suppose…?
Why I’m not able in Roon jpleyfetmo able to resample at 44.1 and anyway I play 44.1 files via Roon jplayfetmo even we have not 45.1 in Roon jplay config…?
Roon said: audio devices (jplay fetmo) not available ,in 24/96.
Do you need a debug ?pls let me know ,I have to resolve this problem because I want to stay with Roon,but I wan to use jpleyfetmo to.
Many thanks in advance Giovanni.

Why I’m not able in Roon jpleyfetmo able to resample at 44.1 and anyway I play 44.1 files via Roon jplayfetmo even we have not 44.1 in Roon jplay config…when the file is 16/44.1 so what …is the problem ?
Roon said: audio devices (jplay fetmo) not available ,in 24/96.

So…what can I do…is not a jpleyfetmo problems it can do any frequencies of course.
Pls let me know.
Tks Giovanni.

Win10 last update Lenovo


I play Roon via smart phone with its app (but in local I’m facing same problem)
Tim wifi with tim standard modem

Art legato usb to spdif converter only 16/44.1
Naim dac ,last firmware.

I’m able to play only 16/44.1 files, via my usb hda or qobuz using jpleyfetmo ,if the file is 24/96 I can’t.i try in Roon jplay config to resample from 24 to 16 and it was fine but no options for 44.1 and its multiple? Why…?
So I have to change my output to art legato who makes 24to16 and 96to44.1 resample.
With the same hardware I’m able to play qobuz 24/96 and more resoluted files via jplay fetmo output.

Any help pls ?
Tks Giovanni.

Hi @giovanni_brunetti,

It’s a bit difficult to understand what you want to achieve here, but if you’re just looking to set a max sample and bit rate for a zone in Roon, you can do so in the Device Setup tab (Roon Settings -> Audio -> Cogwheel next to zone -> Device Setup).

You are right, this is the right configuration, but works only for files 16/44.1, if files are for example 24/96 and my audio device usb artlegato usb to spdif is only 16/44.1 , I hear nothing ,I get the error:
The system (Roon) can not communicate with the device,so by your screenshots (just a bit different than mine) I try to found a downsample to 44.1 ,but we have only 48 and is multiple…
With the same hardware I can play qobuz 24/96 files directly with no Roon involved and as output i use jpleyfetmo, so it seems to be a problem not related to my hardware neither jpleyfetmo.

This is a screenshots of a 16/44.1 file ,all works fine.

This is a 24/96 files always from qobuz but I get this error:

As you requested I post screenshots:

Hi,any news on how to play HQPLAYER?
Tks Giovanni.

Hi @giovanni_brunetti,

It sounds like there are multiple issues going on here, so I believe it’s best to start from basics and verify if the DAC works properly with Roon without any of the 3rd party apps. Can I please ask you to:

  1. Exit out of HQPlayer/JPlay and have the Naim DAC connected via USB to the Core
  2. Enable the WASAPI driver and make sure to turn on Exclusive Mode in Device Setup (Roon Settings -> Audio -> Cogwheel icon -> Device Setup).
  3. Try playing back various sample rates and bit-depth rates on the DAC and verify if the sample rates work as expected through Roon (without the 3rd party modifications).

After you confirm the basic functionality through Roon (and only after), you can look into setting up HQPlayer by following our HQPlayer setup guide (

Hi,n dac by Naim has no USB input, I use an artlegato usb to spdif converter , so my
Chain is
P.C./artlegato usb to spdif/n dac by Naim/RCA output.
Artlegato does only 16/44.1 and I can use its windows drive to resample other frequencies, for example 24/96 and all works fine.
In this situation I follow your instructions.
Pls let me know if it’s ok for you.
Tks Giovanni.

Hi @giovanni_brunetti,

If the Naim does not have USB, then yes, please connect the Artlegato directly to the Core, bypassing HQPlayer and JPlay to verify if it supports the other sample rates without HQPlayer/JPlay involved.

Hi,i follow your suggestions and everything is going very well.
Let me know what I need to do now to integrated HQPlayer.
Tks Giovanni

Hi @giovanni_brunetti,

Glad to hear that the DAC is working as expected without the extra software. Now we can take a look at integrating HQPlayer.

First, please follow the instructions listed in this guide:

If you run into issues following the guide, please provide screenshots of where you got stuck.

First af all TKS for support

Now I try config Roon

Roon and HQPLAYER are on the same machine, so local host is o.k.
Any anyway in HQPLAYER I don’t have the icon for lan configuration…?

Audio setup I leave the default, is it o.k ?