Roon and Photoshop

I’m sorry, but I’m not sure how to categorize this question. This is more of an observation and a curiosity if anyone else in Roonville has experienced what I’m experiencing.

I’m a portrait photographer who uses Photoshop on a regular basis as part of my workflow. I’ll spend hours retouching a collection of portraits and when doing so, I love to listen to music. I’ve noticed that when Roon is playing in the background is when I experience poor behavior with some Photoshop activities. I don’t want to go into the specifics here unless another Photoshop user wishes to engage with this topic. My workstation is a 27" iMac 3.6 Ghz 8-Core i9 with 40 GB of RAM. My Roon Server is located on a Mac Mini which I have set up strictly as a Roon machine. I use the Roon app on my iMac which connects to my small audiophile system using an AudioQuest DragonFly. The nondesirable solution would be to connect the audio system to the Mac Mini. I hesitate to do so because I also enjoy iMac audio going through the small audiophile system, such as YouTube, Bandcamp, educational videos, etc. I would love to hear the thoughts of others if you so desire. Cheers! Devin

I started reading your post and immediately thought that RAM would be the issue - both Photoshop and Roon are RAM intensive - but then got to the part where you mentioned you have 40GB in the iMac, so I suspect it’s probably not RAM related. That said, take a look at Activity Monitor next time the problem occurs as it might shed some light on what’s going on.

I also use Photoshop on the same Mac mini M1 (16GB RAM) I use to run my Roon core, so feel free to share some specifics as to what you’re doing in Photoshop when you experience the problem.


I guess it depends what you’re doing in Photoshop. I’ve seen PS eat almost all of my 36GB of ram and max out 8 CPU cores when doing things like panorama stitching. I’ve not looked at resource use when doing frequency separation retouching, but similar activities (brushes etc.) in Loghtroom can be very resource hungry.

1 Like

Do you have PS set to use all available memory or limited to some portion? I seem to recall that was an option but maybe it was lightroom. It has been a few years.

1 Like

Photoshop has an option to limit its upper RAM use… sadly ROON doesn’t have the same. So while we can stop photoshop from breaking ROON, its hard to stop ROON from breaking photoshop :slight_smile:

You could use task manager to change the resource priority on the ROON instance and back it off in terms of CPU use, or even just dedicate it against a core of its own (e.g. on a 12 core machine, put roon on 11 and 12, as photoshop will fill the earlier cores first).

1 Like

So your Photoshop PC is not the core just a client connecting to a core on a different PC?

1 Like

It sounds like mixing work and play is going to be hard. I used my Core for odd bits of dev work, MS Visual Studio is also a bit of a RAM Hog , I finished up closing Roon to work !! This was using the Dev PC as the core it shouldn’t be as hungry as a remote app.

A daft suggestion maybe, The Dragonfly range (I have a Red) runs as a plug in DAC of both iOS and Android (OTG) so why not simply use a Phone or Tablet/iPad to connect the Dragonfly and leave your primary PC for work. I is unlikely to affect SQ.

When I was working (Long Ago) I used a iPod and Headphones so it was independent of the PC , same principal

Just a thought.

1 Like

Could be a graphics issue.

Experienced this with running an older version of Prusa Slicer. Adobe CC (and other software) would loose performance untill i closed the Prusa Slicer application.

I edit large portrait, files from a Nikon D850. I create multiple adjustment layers and image layers that end up being 2 gigs or just under once finished. The problems I experience are mostly zooming in and out of the image using the command and space keys. The zoom feature can lag or not respond at all when running Roon. Sometimes, it will just freeze up and won’t allow any response from other tools clicking through layers but will allow to save and close. Which is what I do. I can reopen the file, and all works fine until the history state begins filling up again. I originally was blaming it on buggy Photoshop releases but observed the other day, when I wasn’t using Roon, things were running more smoothly.

I have it set to use 70%. This is adjustable through the Performance tab in Preferences in Photoshop.

That is correct, Rugby. My workstation, the 5k iMac, is only acting as a client.

It’s a good thought, Mike. And one I may consider. However, as I mentioned, I have a small audiophile system as my desktop system, which I enjoy using outside of Roon too. I watch a lot of training tutorials and YouTube videos, and I sample music from websites like Bandcamp and such. It’s really nice having such rich audio for these other tasks.

OK, so it does sound like this might be a RAM issue, but I’m puzzled as to why the Roon client would have such a significant impact as it doesn’t use a huge amount of RAM. What settings do you have for ‘Performance’ in Photoshop? Specifically, what are your settings for ‘History States’, ‘Cache Levels’ and ‘Cache Tile Size’?

Also, what does Activity Monitor show when you run into problems? Is there any indication that you’re running short on RAM or that memory pressure is into the red?

I’m a Creative Cloud subscriber, running on an M1 mini and M1 MacBook Air (both the basic models), what I find is that when I’m in Photoshop or Lightroom it’s my network that takes a massive hit and I have to use my iPad or iPhone to control Roon. If I open Roon on the same device it feels really laggy. I have just put it down to my current network setup which is not ideal.

My Core is on a home built truenas box.

I would try uninstalling Roon and install Roon Bridge. Then use a tablet or second machine as “remote” with the Mac zone selected. This will eliminate any “graphics” issues from the Roon software causing issues. If all your issues go away then there you go. If the issues remain then you’ll know that it’s the audio playback which is causing the issue and the only way around that is to stop using the Mac for audio. :frowning: