Roon and Sonos not getting along (Roon lost control of the audio device /

After all the issues I described here
, I replaced my Chromecast speakers with a set of Sonos:Play One. However, the Sonos are being quite temperamental with Roon, too!

Today I received the error “Roon lost control of audio device” multiple times.
The first times I was trying to play a song (256Kbps mp3) stored on my NAS: the song would start, play a couple of seconds, then stop, then play, then stop again, then “Roon lost control of the audio device”.
Most of the NAS content is indexed in the Sonos app, so I ran that, and it played the very same song just fine
A few hours later, I managed to play it through Roon, too.

I then also received the error message while trying to play a song from Tidal.

Any suggestion on what could be causing this?

I have checked the log, and searching for “lost” I find some details, but not sure how to interpret them: I see “lost conection” and “lost endpoint”.

My setup is:
Roon core 1.6 running on a Synology DS918+ NAS with 8GB of RAM, and installed on a Samsung USD SSD drive connected to the NAS.
Roon remote running on a Huawei P20 Pro phone (so Android)
3 Sonos Play:One in the house

Network Topology: Asus modem/router
The NAS and one Sonos (living room) are connected to the Asus via ethernet cable
The other two Sonos via wifi
Excellent wifi throughout the house; the issue with the song on the NAS happened when I was in the same room as the NAS, router and 2 speakers.

The Sonos Network matrix is this:


Hi @YetAnotherLondoner,

First, I noticed that the Synology you’re using for your Roon Core falls short of our recommended specs.

Because this device uses a Celeron processor you may experience performance issues, particularly with larger libraries or DSP, or if you don’t use an SSD for your Roon database.

It’s hard to say whether the issues you’re experiencing are related to performance, but we do like to give people a “heads up” when their system is under spec, since it can impact the product in a number of ways, and you may encounter some limitations going forward.

Moving forward with troubleshooting, can you confirm whether this behavior occurs when playing to a single endpoint or only when playing to all of them? If you play just to the Ethernet connected Sonos do things work okay?

When it occurred, I was trying to play to living room + kitchen at the same time. I also tried to play to only one of the two (first living room only, then kitchen only), but no change. The living room speaker is plugged into the router via lan cable. The kitchen speaker is wireless, but it’s about 4 metres from the router, and with clear line of sight.

I understand my NAS only runs a Celeron processor and that Roon is very resource-intensive, but let’s also not lose perspective: that NAS can stream 4k with hardware acceleration and HD video without (as per the compatibility list on Plex’s website); streaming a single 256 Kbps mp3 with no equalizer settings and no on-the-fly transcoding does not require a server farm - in fact, I used to do it about 18 years ago with the hardware available at the time!

It’s also odd that, a few hours later, it worked fine. There was no other traffic through the router as everyone else in the home was aslepp; at most the Nvidia Shield or the NAS may have been running some background update over the internet, but my internet speed is ca 50 Mbps and certainly doesn’t max out the router (still plenty of bandwidth for internal traffic).

It also never happened when using my desktop PC as an endpoint, even though it’s two floors up and connected via wifi with a signal that’s not as good as in the same room as the router.

PS Roon is installed on a Samsung USB SSD drive connected to the NAS via USB

Hi @YetAnotherLondoner

Just to confirm, are things still working okay for you now when playing to these devices?

Today it worked fine

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.