Roon and Sonos not working in a group setting

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I cannot get Roon to play to a group setting through my various Sonos speakers. It cuts in and out frequently and is very annoying. I’m running Roon through my MacBook pro. Having this capability is the only reason I’m subscribing to Roon and if I can’t get the problems solved I’m cancelling my subscription.

Robert I suggest trying to link them in the Sonos app as that has worked much better for me.

Sadly Roon/Sonos have been getting more difficult to use in my experience for the last year. If you’re Sonos device’s support Airplay then that might also be worth trying as well as a number of user’s have said to me that that has worked better. Sadly only a subset of mine do

1 Like

As Michael notes, Roon/Sonos issues have become more prevalent over the past months. One method I believe may work from what I have read, besides Michael’s AirPlay approach which is a great option, is to make sure the Sonos devices are connected directly using your WiFi or Ethernet network and not using the SonosNet wireless networking approach.

1 Like

Robert that worked perfectly for me for a while and I think for those that can do that, it’s also good advice. Some of the issues caused by SonosNet especially on Mesh networks are a real problem.

Sadly like other’s all my SonosNet devices fall off the network after about 3-6 hours after each restart even on WiFi only. Roon have said they are working on a fix for those of us that have this issue.

1 Like

Hey @Robert_MacLeod,

Thank you for reaching out to us with your question. My apologies for the delayed response and for your wait. We’ve made some recent changes to the support team structure and some reports have experienced a longer response time than usual.

Since some time has passed I wanted to touch base to get your current status. If you’re still experiencing this problem and need assistance please let us know. Both @Michael_Harris and @Robert_F are steering you in the right direction in terms of what to test first.

Also, if you could please fill out a more detailed breakdown of your setup on your original post, that would be immensely helpful for the support team :pray:

We’ll be watching for your reply and get back in touch as quickly as we can. Thanks!