Roon and Sonos Port

After months and several attempts to listen to music with Roon via Sonos Port, I unfortunately have to give up because of constant interruptions and “looking for distant cores”. Roon definitely does not work reliably over the Sonos port. I have to take advantage of what Roon has to only listen to music with Sonos without Roo. That’s good too, because with Sonos I never had any interruptions.

Is your port hardwired, or if you have multiple Sonos devices, one of them, or are they connected to your router via WiFi?

I ask this because in my main listening room, my Playbase is connected directly to the router via 1GB line and all other Sonos devices are powered via SonosNet.

I’ve never had any significant problems with this configuration and I can run my total of ten devices all at the same time.

Hi @Ramiz_Muminovic I have a similar setup to @florib with a Sonos Amp connected via Ethernet, and using Orbi Mesh wireless and it works perfectly to 5 Sonos zones (including out in the garden). Though I have since connected a couple of zone’s to Ethernet Via the Mesh network (though that is a recent development).

I had a lot of initial issues which forced me to improve my network setup and since then thing’s have been great. I remember one of the issue’s being multicast that was forcing the music the be sent to each zone which caused dropouts and skipped track’s. I enabled IGMP Snooping on my router and the problems went away.
I am hoping that helps you in a small way.

1 Like

My Sonos port is connected to a router with a cable and analog to an integrated amplifier + two floorstanding speakers. There is only one zone, no wireless speakers. QNAP NAS HS 251+ is connected to 1200 albums and also with cable to router. QNAP NAS is Roon Core controlled with the Iphone-Ipad app. My problem is that only 1, 2 songs run well via Roon, or only 1/2 then suddenly the output stops and the app message: Roon is looking for a remote core, or no connection to the audio device. Qobuz is still running on Sonos. I have the same dropouts with Qobuz as well as songs that are stored on NAS.

Ah ok. However, I can’t imagine that this is a specific problem that only affects the Port. As far as I know, all Sonos devices use the same protocol (I could be wrong, of course).

Do you have just the Port hanging on that network cable or any other devices (via a network switch) and are they working properly?

Are you running your core on a separate device (NUC/Nucleus) or the all-in-one (i.e. graphical interface and core in one) installation?

Is the Core hardwired (which is highly recommended)?
Your mentioned sympthoms speak in my opinion that this is not the case.

By the way, I use TIDAL and Qobuz without problems.

Have you tried to disable wireless on this device in the Sonos application.

What is your Roon core, mine was on a Synology when I had a lot of issues and it wasn’t really man enough for the job.

As an additional check are you running and kind of DSP or other effects on the output, if so try turning it off.

Edit I see Florib beat me to a couple of these questions

1 Like

With the SONOS alone, without Roon, I’ve never had a problem. Qobuz is running fine, NAS is running fine. Before with the CONECT and now for almost a year now PORT music playback works great. With Roon platform I wanted to upgrade … bought a license … and unfortunately everything for free. My Internet is very fast, as I said, Sonos and Qnap NAS are connected to a router via an ethernet cable. Qnap is Roon core with the latest update.

Roon has some demands on networking so it’s worthwhile looking at the guide’s and looking at the settings mentioned above. Worked great for me and it has nothing to do with the speed of your internet to be fair.

Things like turning off WiFi on the Port and multicast are important and worth investigating if you want to get the network working well.
I could only really play 320Kb MP3 reliably before I made the changes in my network back in 2019

I think your NAS might be a little underpowered to serve as rooncore, with just 2GB of RAM (Roon recommends 4GB - FAQ: What are the minimum requirements?); as both the Sonos port and NAS are wired to your router, i don’t think the network is to blame (unless you have a faulty cable - depending on your router you can check for ethernet errors on its interfaces).

To verify if your QNAP NAS HS 251+ (serving as Roon Core) is the bottleneck or not, i can think of 2 test scenarios:

  • point Roon’s storage folder to a new directory that only has 20-50 albums
  • move your Roon Core to a spare PC

Maybe RAM is too small. It is expandable up to 8 GB. I will then upgrade RAM and hope that Roon will be more stable. I read somewhere that only from Nucleus Audio Server Roon works without a topper. I now lack the coins I need for this.Thank you all for valuable tips.

Hi Ramiz you can always build a Nuc for under £500 (or there are plenty of second hand ones available) or so I’d you want a dedicated music server and run Roon on Rock or you can try a Windows PC. Plenty of options without spending £2k

I think I wrote that I used to use a Synology and had lots of dropouts on that as well,