ROON and the Qobuz Sign in

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

UK Vodaphone broadband, Ethernet connection

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Auralic vega G1 with Hegel , Sonos endpoints and IPhone/Ipad controllers

I cannot sign into Qobuz via Roon yesterday or today, but appeared to be fine the day before. I have changed broadband supplier on Wednesday. Roon rebooted, apps deleted on controller devices and re-downloaded. Access to Qobuz on Ipad and controller is normal and constant outside of Roon.
All internet connections are secure and solid, currently experiencing 63.1-71.5 Mbps.

Hi @alex_wood,

How are your DNS servers set up? Are you using Cloudflare DNS, Quad9 or Google DNS on the router?

Also, can you send me a copy of your Nucleus logs? You can access via these instructions and upload to Dropbox / Google Drive / / ect.

As requested, please find logs here:

As to DNS server set up, well I have to admit I would not know how Vodaphone UK do that, its beyond my understanding.

Hi @alex_wood,

Thanks for sending those logs over, but these appear to be from the Windows client, not the Nucleus Core. Can you please first reboot your Nucleus Core and then send me a new set of logs from the /Data/RoonServer/Logs folder?

Nucleus Core

  • Using a Windows machine, open File Explorer and navigate to \\NUCLEUS\Data . You should then see the RoonServer folder.
  • Using a Mac, open Finder and navigate to smb://NUCLEUS/Data . You should then see the RoonServer folder.

Be sure to replace NUCLEUS with NUCLEUSPLUS if you have a Nucleus+

As requested, this time the correct Logs

Hi @alex_wood,

Looks like the upload didn’t go through as expected here… Can you please re-upload on our diagnostics servers instead? I have created a folder for you here.

Upload complete now

Hi @alex_wood,

Thanks for sending those logs over. I’m looking through them and it would appears as if your Nucleus currently has no internet connection:

6/17 14:20:10 Critical: [easyhttp] [344] Get web exception without response: : System.Net.WebException: Name or service not known Name or service not known
 ---> System.Net.Http.HttpRequestException: Name or service not known
 ---> System.Net.Sockets.SocketException (0xFFFDFFFF): Name or service not known
   at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken)
   --- End of inner exception stack trace ---
   at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken)
   at System.Net.Http.HttpConnectionPool.ConnectAsync(HttpRequestMessage request, Boolean allowHttp2, CancellationToken cancellationToken)
   at System.Net.Http.HttpConnectionPool.CreateHttp11ConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken)
   at System.Net.Http.HttpConnectionPool.GetHttpConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken)
   at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
   at System.Net.Http.RedirectHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
   at System.Net.Http.DecompressionHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
   at System.Net.Http.HttpClient.FinishSendAsyncUnbuffered(Task`1 sendTask, HttpRequestMessage request, CancellationTokenSource cts, Boolean disposeCts)
   at System.Net.HttpWebRequest.SendRequest()
   at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   --- End of inner exception stack trace ---
   at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at System.Threading.Tasks.TaskFactory`1.FromAsyncCoreLogic(IAsyncResult iar, Func`2 endFunction, Action`1 endAction, Task`1 promise, Boolean requiresSynchronization)
--- End of stack trace from previous location where exception was thrown ---
   at Sooloos.EasyHttp.QueryAsync(HttpMethod method, Params p, CancellationToken canceltoken)
06/17 14:20:10 Warn: [qobuz] [http] error result from http request: System.Net.WebException: Name or service not known Name or service not known

Have you tried rebooting the Nucleus and networking gear yet? If not I would.
We also released a new build earlier today, has that changed anything?

It appears you may be right, but I have a network address but cannot update software
You asked me to reboot before sending logs, so I did, I will do it again and check Ethernet connection etc

I have now connected my network switch directly to my router rather than a power line connection (very long Ethernet cable!) but there is no difference I can see.
I still can’t log into Qobuz or update Roon, so it appears connected/disconnected.
Please see my router network connection for Roon added to this as screen shot!!
My innuos zen and auralic dac are all networked from same switch and are connected.
My auralic G1’s dac is also connected to Qobuz in its lightning software!
So, I’m confused!


I have now taken network switch out of the situation and connected Nucleus directly to router, still I can’t connect to internet, update or login to Qobuz
All my other internet connected devices in my house are functioning normally!
I have rebooted nucleus twice and no change.
It looks like a ROON/nucleus issue doesn’t it?

Hi @alex_wood,

What does your Web UI for the Nucleus look like?
Can you share a screenshot of that tab?

Click on link above, i included it earlier “image 231x500”

Hi @alex_wood,

That’s not the Nucleus WebUI. It should look something like this for reference:

Doh, my bad, I had a complete brain fart there…

Ah, have I got a problem with my gateway and DNS server settings and if I have, how on earth do I resolve that?

Pick DHCP and see if it populates.

I have manually populated the DNS and gateway, boom, it worked.
Noris you led me too it and I clicked!
Thanks, lesson learnt there


Hi @alex_wood,

Glad to hear you got the DNS setting fixed up and now Roon is working!