Roon Android App not connecting

I have been a new setup of Roon with a nucleus, year to year, but will upgrade to lifetime if all issues are resolved.

I have it Ethernet attached to my network (Orbi base with 2 satellites) Xfinity 160 MG/ down-10 MB-up typical speed. I am running Roon on their nucleus/Tidal and music loaded via USB WD-1TB My Passport Ultra drive, which can normally see the Kef LS50-W and attach to them,

Biggest issue,

  1. Android App Pixel 2 XL & older Samsun Tablet are not connecting or only sometimes connecting after a longer than can be expected wait. What can be done to eliminate this wait. I am in the same room with the nucleus (software updated 10/5/18) and an Orbi satellite. I did notice that it stated the library database was 95% full, but I only have 2,500 albums and 600 Tidal albums, so I can not figure why the database would be that full. Most of the time it will load on my Win 10 64 PC but there is still a wait.

Hello @David_Wilson1,

Thanks for contacting support, I’d be happy to assist here. I have a few suggestions:

  • Can you please make sure that the Android devices are on the same network as the Core and you are not using a “Guest Network” here?
  • Since you are using an Orbi setup, can you please try unchecking “Disable IGMP Proxying” in the Orbi Router to see if this reduces the connection delay?
  • Is the Nucleus connected to the Orbi Router or to a Satellite? If it is connected to a satellite, does connecting the Nucleus directly to the Router improve things?

Please let me know when possible.



Unchecking “Disable IGMP Proxying” made a huge difference, maybe solved it. I try it for several days and see if it slows down again.

I do have the Nucleus connected to the Orbi to one of the two Satellites, which is currently dedicated to the Nucleus and Ethernet connected. What issues may arise using Satellites? I would have to change some of my wiring, small hassle but doable if using a Satellite will cause issues. I was getting great bandwidth so I had thought it would not be an issue.

Would Implicit Beamforming or MU-MIMO tend to improve things or introduce issues?



Hello @David_Wilson1,

Glad to hear that Disable IGMP Proxying has helped in your setup!

For your question regarding network setups, we have seen the best performance when everything is hardwired via Ethernet directly from a consumer grade Router or an Unmanaged switch.

Our Networking Best Practices Guide outlines some of these recommendations but using WiFi to communicate will be less reliable when compared to using a dedicated Ethernet port from your Router or switch because it relies on the WiFi spectrum (2.4Ghz /5Ghz) and is subject to RF interference from other devices that also use this frequency. Beamforming or MU-MIMO will still have the same RF frequencies so while it can provide some improvement, direct Ethernet connections are advisable for the best stability and throughput for any given setup.

With that said, if you aren’t experiencing issues here and everything is working as expected after the Orbi settings configuration change, there may not be a need to make such a dramatic change to the setup. I hope this helps.