Roon App Cannot Configure Core

Core Machine (Operating system/System info/Roon build number)

Roon Rock, NUC i7 w/16GB RAM, version 1.7 (build 710)

Remote: Samsung S21 Ultra w/16GB RAM (app version 1.7, build 610)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus AC2600, cat 7 ethernet, 600 mbps

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.) *

Mytek Brooklyn Bridge

Description Of Issue

My remote device is having difficulty consistently connecting to my ROCK. I often get stuck for minutes with at Waiting To Connect message and I am not able to Configure Roon OS in the Setup menu.

Images attached for context.

Add images

Hi Kursten

I’ve moved your post to the Support section where it will be seen by Roon Support.


I can now configure my core from my Samsung S21, but it still takes MANY MINUTES TO CONNECT TO THE CORE. I’m one of many people who are having this problem. Where is the solution?

Hi Kursten,

Friendly Fellow User Here trying to be helpful. Some things to try if you have not already:

  1. if you see the cannot connect screen click Help and there should be an option to add an IP address there, if so, use That might work better.

  2. Use the 2.4 Ghz band with Samsung, Samsung phones have had connectivity issues using 5 Ghz WiFi bands.

Android phones can and do work without any issue running Roon. I know I’ve been using them for the last 5 years. Although, I can’t speak for the new S21’s as I only use Notes. I will let you know when I get my Note 21 if/when it comes out, but, the current Note works like a champ. :smiley:

Open up any browser and type in HTTP:\\ROCK, it should find your NUCs setup page. Then bookmark that page. All that link in the Configure page does is open up a browser anyway.

You do not need the Roon app to be open to access the NUC’s web page. Try the above without have the Roon app open. How long does it take to open?

1 Like

Thanks, Rugby!

I was able to access my core from my app and it now shows up consistently.

Unfortunately, my core connection issues are happening both on 2.4 and 5Ghz. Next time it fails to connect, I’ll definitely try your IP address suggestion.


1 Like

Can someone from Roon support please weigh in here?

Hello @Kursten_Hogard,

Apologies for the difficulties you are having here!

Can you please confirm if you have enabled Multicast routing on this device as per our Networking Best Practices Guide?

ASUS Routers

We recommend enabling “Enable Multicast Routing” option in settings.

Does this behavior also impact non-Android remotes such as a Windows or Mac PC?

1 Like

Hi Norris,

I’ve followed all of the recommendations in the networking guide.

My ipad connects reliably, but there’s always a slight delay, which is why I never use it as a remote. My old Lenovo android tablet won’t connect. I just booted up my old Samsung Note 8 and it connected right away.

On the S21 Ultra, I can either choose to not optimize the battery for roon or I can choose to never put the app to sleep. The options are mutually exclusive. Which should I choose? Neither seems to make much of a difference.

My Nexus tablet also won’t connect.

Hello @Kursten_Hogard ,

Just to confirm here, this is the only router in your setup or are there some range extenders in the mix too?

Does it connect by manually specifying the IP or does this not work as well? Any VPNs on the Nexus?

Hi Noris,

Yes, that is the only router. No extenders or switches in the chain.

No VPNs on any of the devices. Manually entering the ROCK ip address yealds nothing after 5 minutes. I never use the nexus, but would like the S21 Ultra to perform as reliably as the Note 8.

My S21 Ultra is connecting more quickly and staying connected for longer than before, but it still isn’t consistent and stable like my Note 8 is.

Can you please let me know if it’s better to choose to have roon set to “never sleeping” or to have “battery optimization” turned off. Unfortunately, I have to choose between the two.

Performance is much better with the new build, but the connection still drops out briefly but frequently.

Well it worked pretty well for the first 24 hrs, now it has lost connection and it can’t find the core for the past five minutes and counting. I’ve entered the ip address manually (again) and it still isn’t connecting.

Hi @Kursten_Hogard ,

Are you on the latest router firmware? Do you by any chance have another router you can try to temporarily use?

Is there any change in connection if you try to reboot the remote that doesn’t connect or toggle it’s network off/on?

The router firmware is up to date and I don’t have another router, unfortunately.

I’ve rebooted the remote app and uninstalled/reinstalled it, but that doesn’t help. Turning wifi off and on or switching bands doesn’t help either. For what it’s worth, my Note 8 works on 2.4 and 5g.

I just updated the remote app on my Note 8 and it still works great. It really seems like the problem is specific to this S21 Ultra.

1 Like

Hi @Kursten_Hogard ,

Thanks for confirming that the issue is only occurring on the S21 Ultra! Is there by any chance a change in behavior if you perform an operating system reinstall on the S21? It sounds like there is a multicast issue with that device.

I don’t think doing a full system reinstall on my S21 is a viable option. This phone is heavily modified and it would take forever to restore the settings. It’s easy when I upgrade a phone, because I can transfer the settings from the old one. But, I sold my old phone and don’t have that to use as a backup.

Have you received reports of similar problems with other Samsung users?

My S21 seems to be dropping its wifi connection periodically and my S20 did the same thing. Apparently, this is a known issue with both the S20 & S21 Ultras.

For the past few weeks, my phone has been able to connect to my core pretty quickly, but usually it is not instant like it was on my Note 8. When I’ve recently encountered longer connection issues, it is almost always due to the phone losing its wifi connection.

Hope this helps.

Are you still having issues? I just updated my Samsung Galaxy S21 Ultra to the newest Android version and…poof! more Roon connectivity and I cannot use this daily driver as a Roon Remote. I have tried power cycling everything. I have tried uninstalling Roon Remote and reinstalling from Google Play Store. Three times to no avail. It was fine until the update three days ago.

All my other computers and tablets have not been affected, Roon still works fine. However, my main Roon touch point is my S21 Ultra and it just hangs there trying to connect. Even my old cell phones still work just fine - but I have not updated those in quite some time and all run old Android versions.


That really sucks. I think there’s an issue with the S21 Ultra losing its wifi connection. I found that if I turn wifi off and on the connection works just fine. Often, the wifi connection will drop without indication - the wifi icon shows a connection when there isn’t one. I found that this stops happening if I only use the 2.4g connection instead of 5g.

I read somewhere that Samsung used the wrong radio components for 5g wifi. Something to do with it not being compatible with most 5g routers.

Sorry that I don’t have a more helpful response, but I hope you get this resolved soon.