Roon app crash iPhone 12 Pro iOS (14.3) - need assistance

Can you share if you were able to fix the persistent closing of the app? I’m having the same issue. Did the whole remove, reboot, re install with no success. Really ruins the user experience.

Hello @Nabeel_Sarwani,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

  • Running Roon server on iMac, Catalina 10.15.7, Roon Version 1.7 (build 710)
  • Control via Roon app on iOS (14.3), iPhone 12 Pro (MGJV3LL/A), Roon Version 1.7 (build 610)
  • Mac is connected via wired ethernet. Connected to wireless router.
  • 2 x Blusound node 2i
  • Mainly streaming Qobuz, limited library on Mac.

Same issue is still occurring - Roon app closes from the phone screen after about 5 secs or so, sometimes a little longer, but swiping up shows it still there and reopens where it left off.

Hello @Nabeel_Sarwani, have you reinstalled the app since the crashes started occurring? Does it help?

I deleted it again, after receiving your email, power cycled the phone, then reinstalled the Roon app. Worked fine for 1 night.
Now it’s back to closing by itself again. Same issue.

I am having the same problem with frequent, regular and quick crashing of the Roon app on my Apple iPhone 12 Pro. I have deleted the Roon app and reinstalled it with no change. Interestingly, I have no Roon app crashes on my Apple iPad Mini 4. I am running iOS 14.4. Thanks.

Exactly same issue as described above. iPhone 12 Pro.

I recently upgraded my iPhone X to an iPhone 12 Max Pro and must admit to have experienced the same issues of the Roon app crashing after several seconds. This is not iPhone 12 related, as I had the exact same happening on my iPhone X with the latest versions of iOS. I’m using an iPad with the Roon app to use Roon most of the time. Never had that unit crashing on me.

1 Like

I have done some extensive testing and have come to the following conclusions:

  1. For Innuos users, the recent model (iPhone X through 12) iPhone IOS Roon app crashing is caused by the Roon core settings to include Squeezlite. Once that Innuos Core setting is changed to just be “Roon Core” with Squeezlite eliminated, the Roon iOS app crashing is fixed.
  2. I think something happened with Roon 1.6 and 1.7 and it’s ability to recognize the Innuos Phoenix USB reclocker. The Phoenix will pass data to the connected DAC. But the Phoenix is not recognized as Connected to Core in the iOS Roon app.
  3. Sometime during Roon 1.6 and certainly in 1.7 Squeezlite and Squeezebox failed to work on the Zenith.
  4. My DACs are recognized as Connected to Core if connected directly from my Zenith via USB DAC out to USB in on my DACs, bypassing the Innuos Phoenix. This is good. But it renders my Phoenix unusable unless the Phoenix is connected to a Roon endpoint such as a Sonore UltraRendu.
    Dear Roon Labs: please fix this situation whereby Squeezebox and Squeezlite work again but without Roon iOS app crashing and please get the Roon app to recognize a DAC connected to the Phoenix as “Connected to Core”. Thanks.

Same here, it’s frustrating!
@nuwriy - could we please take a look at the issue? With many of us using larger mobile screens, such as the iPhone 12 Pro Max, this sudden crash shouldn’t be happening. Let’s fix this thanks.

And the same here. Has been around in the past, the iOS crashes never vanished completely. Today it’s totally unstable. iPhone 12pro (did have same issues on previous models). This needs to to. Pls @nuwriy have a look. Thanks

Edit: app re-installed. Caches and history erased. Multiple re-starts of the iPhone and the iMac (27", late 2009) - nothing helps

Did an install of a security update in my iMac, which serves as my Roon Core.
Ever since that, the iPhone app on my 12Pro has been solid - no crashes.
All software still shows the same versions (roon Core, iPhone Roon app, and iMac OS), but maybe this now stable performance on the phone is related to this new updated that was just completed to Catalina?

Nah-premature post-back to the same… app closes again after a few seconds.

Sorry for getting hopes up!

Same issues here on iPhone 12 Pro. Love Roon, but not being able to control it from my phone with an unstable app makes it useless. The fact that the issue still isn’t solved really worries me.

Was your current iPhone setup inherited from your previous one(s)? Mine is. And my company iPhone does not reproduce that erratic behavior within the very same environment. So if you can - start with your phone from scratch (no! restore from backup) and see if that helps.

My current take is something is screwed in my backup (had calendar issues as well) that somehow impacts Roon. This does not let the Roon development off the hook but might be a way to examine further.

Same here . Roon core is on an Innuos mini mk2, new installed Roon app.
app is crashing on both iPads. One tap…crash!

Which language settings? iPads and app. Tried to switch to English for both?

Are you running Roon 1.7?
If so, is your Roon core set to include Squeezlite?
If so, set it to Roon core only and see if the iOS app is more stable.

Hi everyone,

For crashes related to Settings, we’ve released an update that addresses this. More info can be seen here:

If you’re seeing crashing not related to this, please see the post here: