Roon app crashes overnight

Roon Core Machine

Roon Nucleus
Roon Version 1.8, build 1021

Networking Gear & Setup Details

Network is hardwired ethernet.

Connected Audio Devices

dcs Vivaldi system.
Roon connects via ethernet to the Vivaldi Upsampler.

Number of Tracks in Library

Local music library is on a Mac Studio computer, 8TB SSD, macOS Monterey Version 12.5.1.
Total Roon library (including Tidal tracks) is ~59,000 tracks.

Description of Issue

Almost every morning for the past 10-15 days, I find the Roon app is no longer active on the Nucleus. Happened again this morning for at least the fourth day in a row. To get things running again, I have to disconnect the power cable from the rear panel of the Nucleus and plug it back in after waiting about 30 seconds. In these situations, the ON/OFF switch on the Nucleus is lit but does not function at all. Once restarted, Roon and the Nucleus run perfectly fine for the rest of the day and throughout the evening, playing with no issues from Live Radio, Tidal and my local library. But something always seems to go wrong between the time I shut down for the night (typically early morning hours) and when I check the next morning to see if Roon is operational.

An additional data point that may be relevant (I don’t know) is that we recently had three power outages in my residential area (this is California after all), each around 3-4 hours in duration, once on Sunday, August 21, and twice on Wednesday August 24. Following the 3rd outage, Roon appeared to go through an extensive process to rebuild its onboard database from scratch, “adding music” from my local library for several hours following the outage. But once that process was completed, everything appeared to be well again – except I keep discovering virtually every morning that the app has crashed. FYI, the Nucleus is NOT plugged into a wall outlet, but into a high-end Transparent Audio power conditioner that supports the entire audio system.

What can I do to get the Nucleus/Roon running reliably again 24x7?

Hi Charles,

This is not quite a direct answer and I’m just a fellow Roon user.

I would suggest a UPS so that if the power goes out you can turn off the Nucleus gracefully before it crashes due to power loss. As with any computer, but, especially one which keeps the database in memory, just cutting the power can result in a corrupted database.

Thanks. And I may well invest in a home generator in the not too distant future. But it is not power outages that are causing the current failures of the Roon server app each and every morning somewhere between 4am and 9am.

Hey @Charles_Craiglow,

Thanks for taking the time to write in, and I’m sorry to hear you’re running into issues with roon crashing.

After looking into your account, I see you have both a Nucleus and a Nucleus+, can you please provide more information as to which machine is having this issue?

When you mention shutting down, are you referring to one of your devices being used as a roon remote?

If possible, please reproduce this issue and share a specific timestamp (date, time) of when this issue occurs. That way, we’ll enable diagnostics on your account to take a deeper look.

I’ll be monitoring this thread for your reply :+1:

Hi Benjamin
Let me give you some additional background. The dealer who originally installed the Nucleus and who has been extremely responsive and helpful in working with me to resolve these problems is Music Lovers in Berkeley, CA. The contact there is Hugh Fountain.

I’m now on my third Nucleus. The first was installed in Sep 2020 and worked great until late June of this year. The second Nucleus died after a few weeks and was replaced with the current (third) one around July 20. The present one worked absolutely trouble-free until about two weeks ago. I didn’t keep a log, so I don’t know on exactly what date the Roon software crashes began to occur. At first, I just thought it was a couple random events.

If any one of these three Nucleuses was/is a Nucleus+, I’m not aware of it. But there has only ever been one Nucleus installed in my home.

When I refer to “shutting down” for the evening, it means that I get out of the Roon Remote app on the iPad; I turn off the power amps in the system; and I switch the Vivaldi gear to standby power. I don’t do anything with the Nucleus itself. But over the past couple weeks, I repeatedly discovered that the Roon software on the Nucleus had crashed sometime overnight and could only be restarted by disconnecting power from the Nucleus and reconnecting it. I can’t tell you for sure whether this system crashing started clearly before the first of the three unexpected power outages I mentioned in the original post or only somewhere during the period of those outages.

I’d be happy to make and send screenshots, but the system crashes have been occurring overnight when the system is unobserved. I only discover later in the mornings that the Roon system is down.

Over the past few days it’s been a bit of a different story.

  • On Sunday morning (Sep 4), Roon had, for a change (!), not crashed overnight. It ran fine throughout the day and all through the evening.
  • Same on Monday morning (Sep 5) until… sometime after midnight (perhaps around 1:00 am) it crashed while streaming music. In this instance, though, it rebooted itself automatically, and resumed playing normally after I pushed the play button in the Remote app.
  • Roon was still running OK on Tuesday morning (Sep 6). In this case, due to warnings of more power outages, I preemptively turned the Nucleus off in late afternoon via the power button. I switched it back on probably around 1:00 am, it came up normally, and was still running OK when I checked it this morning.

I don’t know what to make of all this. It’s pretty clear something’s not right. But it’s difficult to know what.

Regards,
Chuck

Hey @Charles_Craiglow,

Thank you for the details! I’ve enabled diagnostics on your account to take a closer look at things, and I wanted to ask about your Nucleus backup situation. Do you have an SSD you’re saving backups to? Or, are you using Dropbox as a system for your backups?

Outside of this, I do see a handful of network errors in the earlier morning hours that could be playing a role in these hiccups. You mention your network is hardwired, is your core hardwired directly to your router? Are you able to provide more information about your router model, and any details surrounding your ISP?

When in doubt, giving your router and network a hard reboot can oftentimes help in situations like this.

Hi Benjamin,
I have two different backups scheduled. One goes to the SSD on the Mac Studio (same location as the local music library); runs in about 30 minutes. And the other goes to Dropbox and takes 4 to 5 hours to complete. As an aside, since those backups are scheduled at 6:00 am and 9:00 am respectively, I’ve been launching many of them manually, since Roon has usually been down when they were scheduled to run.

I’m a little ignorant about all things network, which was installed by Music Lovers. The internet is supplied by Comcast and there’s an aging Comcast cable modem near the connection point in a room below the listening room. There’s also a network switch there (Netgear, I believe) which allows the cable modem to connect to the nearby eero WiFi router as well as to an ethernet cable running directly up to the listening room. There’s another network switch in the audio cabinet which allows the connection of several ethernet capable devices to the network - Apple TV, Sony Blu-Ray, Roon Nucleus, Vivaldi Upsampler, Anthem A/V processor, Control4 home automation system, and probably others. The Mac Studio connects to the listening room by means of Netgear ethernet-over-powerline adaptors on each end. (I hope I got that all right.)

One more thing worth noting: I’ve scheduled the installation of a replacement for the old Comcast cable modem with a new model (they’re calling it a “Gateway” now) for this Saturday, Sep 10. Perhaps that will help. Although other than outright Comcast outages, the internet seems to run just fine here, and we have not run into problems with other devices.

In the meantime, I can certainly reboot the existing Comcast modem, just to be sure that’s not the source of the problems.

Chuck

1 Like

Hey @Charles_Craiglow,

Thanks for the detailed breakdown! Just as a test, if possible, are you able to try to connect your core directly to your router and see if the same issues occur? When in doubt, simplifying your setup as much as possible can help pinpoint where the issue may lie :pray:

With that, have you experienced crashes over the last few mornings? If so, we’ll re-enable diagnostics and take another look at things :+1:

I very much appreciate your patience here!

Hi Benjamin,
I played music on Roon for a couple hours early this morning (Sep 8, ~2:00am). Later today (~1:00pm) when I checked Roon on the Nucleus, it was down again. I disconnected/reconnected power and it came back up. Then I manually launched the local backup that should have run at 6:00am. Within five minutes or so, Roon crashed again. I went through restarting the Nucleus/Roon again, relaunched the backup again, and this time it ran successfully. Roon is still running now (5:00pm) and playing Live Radio without complaint.

Wouldn’t there be an error log somewhere that would give an indication of what type of hardware or software fault is causing these failures? Hard to believe such a sophisticated system does not have fairly robust error reporting.

Regarding the network – every wired device in the home connects one way or another through that one ethernet port on the Comcast cable modem. If I move the Nucleus to the lower-level office where the Comcast modem is, remove the LAN connection from the modem, and plug the Nucleus “directly” into the Comcast modem, what would that accomplish? Nothing would work. In particular, Roon, could no longer connect to the Vivaldi Upsampler that would be sitting upstairs on the disconnected LAN.

Obviously, I’m not understanding your suggestion properly. As I said, I’m far from savvy in the network space. If I actually need to change the network topology, I’ll need to get someone more knowledgeable about home networks involved.

As it is, I should have a far more recent vintage Comcast “gateway” installed on Saturday, Sep 10. If the problems are originating with the internet service, perhaps that will eliminate them, but I’m not exactly hopeful. I’ll also talk to the Comcast guy when he’s here about whether I can eliminate the network switch in the lower-level office which (I think) is only there because the old Comcast modem had only one useable ethernet port. If the new box has multiple useable ethernet ports, it seems I should at least be able to have the ethernet cable running to the listening room connected directly to the Comcast box rather than through the switch that’s there now, and in theory I’d still have everything on the LAN able to communicate with one another. But again, I’m not enough of a network guy to be certain about all this.

Other than that, what else I should be doing at this point?

Hey @Charles_Craiglow,

Thanks for the additional information. We’ve enabled diagnostics on your account to review the Nucleus logs, but haven’t found anything directly pointing to the issue.

As a next step, let’s get you set up with a fresh RAATServer. You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon Database
  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the RoonServer in the WebUI to generate a new RAATServer

Let me know if your issue persists after the above :+1:

Thanks, Benjamin
Oddly, there does not appear to be a “RAATServer” folder in my “Roon Database Location”. Please see the attached screenshot. Or am I missing something? (None of those subfolders in “Database” contains a “RAATServer” folder.)

Chuck

Sorry, I did misinterpret the instructions. This afternoon I managed to access the Roon Database on the Core and rename the RAATServer folder as requested. Restarting Roon Server did create a new RAATServer folder as expected. See attached screenshot. As of now, Roon is running and playing Live Radio.

Additionally, there is now a new Comcast cable modem supporting the local network. The Comcast technician, who at least appeared fairly knowledgeable, indicated that the local network was properly configured for the functionality required. He also said the old modem was probably getting close to failing outright, so perhaps that has been impacting Roon, who knows?

I’ll definitely let you whether or not I continue to see problems over the few days.

Thanks,
Chuck

Opps, here’s the screenshot.

Hi Benjamin,
After streaming music for 2-3 hours, Roon crashed again last night. I attached a couple iPad screen shots to give you a time stamp. It has not crashed again since restarting last night, but clearly something is really wrong. I’m pretty convinced it’s not a network issue, We have 2 Macs and a number of other devices attached to the network, and none of them has any problems at all. Nor did the Nucleus until a few weeks ago. I’m beginning to wonder if there isn’t some kind of corruption in the Roon database that may be the cause. Please advise. Thanks.

Chuck


Hey @Charles_Craiglow,

Our team took another look into your account and wasn’t able to find anything directly related to the crashes other than a few network issues.

As a follow-up, when your nucleus crashes, does it show that RoonServer restarted in the WebUI?

With that, if you could (again, my apologies) provide a specific time and date of the next crash we may be able to better pinpoint what the cause might be.

Sorry, I have not been checking the Server status on the WebUI after these crashes, but I will after the next one…

FYI, Roon ran fine all day on Sunday, Sep 11. Streamed music until close to 4:00 am on Sep 12. But at 11:30 this morning it was down, as usual. The best I can say is it crashed somewhere between 4:00 am and 11:30 am, presumably while I was sleeping. The next time it crashes, I check the WebUI first and let you what the Server status was prior to restarting it.

Regards,
Chuck

Hi Benjamin,
Roon ran uninterrupted for ~4.5 days, but it crashed again early this morning (Sep 17) after streaming music for a few minutes. In this instance Roon rebooted itself automatically, so I was unable to capture a screenshot of the WebUI status prior to the restart.

Separately, with all the difficulties, I’ve been holding off on installing the latest version of software on the Nucleus as requested by the repeated prompts. Would you prefer that I go ahead and install it, or keep running the 1.8, 1021 build for now?

Chuck


Hey @Charles_Craiglow,

Apologies for my late response, I was OOO last week. Go ahead and update to the latest build, and let me know if you continue to run into issues here :pray:

Hi Benjamin,
As requested, I updated to the latest version of Roon on all my devices sometime in the afternoon of Sep 21. Roon then ran fine until earlier this morning (Sep 25). As you can see from the attached screenshots, what appears to have happened then is that Roon failed while attempting to complete the scheduled 6am local backup. It subsequently rebooted itself, but never ran the backup. After making the screenshots, I launched the backup manually myself, and it ran without incident. Roon is still running fine as of now (4:17pm).

Chuck


1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.