Roon App downloading as an Alias (full app does not install) - MAC OSX Mojave [Resolved]


I needed to re-install Roon on my MacBook Pro (2015) - however, when downloading - the Roon app only shows up as an alias file in applications (clicking on it starts the roon icon bouncing and then disappears after a couple of seconds).

I have gone through and deleted all past versions, and yet the problem persists.

I have successfully been able to download apps from other providers, so have confirmed this is not a system-wide issue.

*I also tried a couple of the recommendations in the knowledge base (inputting the string into terminal and seeing if arial in font book needed to be turned on - both did not help).

Please advise.


I think @support would help you better here. :wink:

You probably want to loop in Roon @support. :smile:

Nonetheless, please confirm that you are running Roon not Roon Server as I’m pretty sure the latter is headless. Also, follow the following steps and post the results.

  1. Make sure that the Roon process isn’t running via Activity Monitor
  2. Reboot your Macbook
  3. Once restarted, launch Terminal
  4. Paste this command into Terminal: /Applications/ and hit enter
  5. If Roon doesn’t launch, paste any error codes and output in your reply


(sorry, inputed wrong tag previously)

Thanks -
tried your terminal command:

jay-kshatris-macbook-pro:~ jaykshatri2$ /Applications/
-bash: /Applications/ No such file or directory
jay-kshatris-macbook-pro:~ jaykshatri2$

That’s you problem. It doesn’t appear that you have installed Roon into Applications. Can you confirm what version of Roon you want to install and that you have downloaded the correct package?

Once you’ve done this you need to double-click on the downloaded file, which will mount it on the desktop (see below), and then drag the Roon application to your Applications folder.


1 Like

Agreed - for some reason though the installer window appears and I drag the app icon into applications folder, only an “alias” file is created and the actual application does not get installed. That’s the problem.

Instead of going the drag’n’drop way, try copy & paste via the right click menu - maybe it does the trick?

Then navigate to the Applications folder in Finder and use Paste Item - what happens?


That worked u_gee - thanks very much for the assistance.
Martin, thank you as well for the help.


**Please try @anon47919701’s suggestion and post the output. But please confirm that you need Roon not Roon Server. Thanks.

Also, can you confirm that Allow user to administer this computer is check in System Preferences > Users & Groups.

Thanks Martin - yes, u_gee’s suggestion worked.
Running Roon, not server and yes, administrator is assigned to the computer under my name.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.