Roon app on Android 10 fails to detect server

Core Machine (Operating system/System info/Roon build number)

Rock 1.6 build 416 on NUC8i3BEH (8GB, 250GB NVMe)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Pixel 3 with Android 10

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue
When my Pixel 3 was running Android 9 (Pie) I had no issues at all running the Roon app. Now that the Pixel was updated to 10, the Roon app no longer detects my Roon server.
I have tried touching the “Help” link on the phone which allows me to enter the IP address. That doesn’t help.
If I turn off the phone’s WiFi and then turn it back on, then sometimes the Roon app will detect my Roon server. But, this is only temporary. As soon as I close the app, and re-open it, it will complaining again of no remote core being detected.

My other Android devices are running older versions of Android and they aren’t having any issues whatsoever.

Anyone have the Roon app running correctly on Android 10?

With me it is connecting just fine after the latest Android Roon app update a few weeks ago. Also on a Pixel 3 with Android 10. Before that update the app wouldn’t even start. The only issue i am experiencing now it that very often the volume up ‘button’ gets stuck and the volume ramps up to 100 and stays there.

Hopefully we will see a big update soon that fixes some issues with Android 10 and Roon. I find myself hardly using Roon anymore at this point and that’s a big shame.

Your experience confirms for me that this is what I suspected - an issue with Android 10.

All of my endpoints have the volume adjustment disabled. So, even during the short periods I’ve gotten the app to connect to my Roon core, the volume glitch didn’t happen.

Yeah, I’m hoping for an update to address this.

Hi @Thomas_Prossima1,

What does your network setup look like, can you let me know the model/manufacturer of all your networking gear? Usually when a device is unable to see the Core, it could indicate an issue with multicast on your network. Knowing the model/manufacturer will help, but I would also suggest reviewing our Networking Best Practices in case there are additional suggestions which apply to your setup there.

My WiFi router is a Synolgy 2600ac. The NUC running Rock, is of course using wired ethernet to a NetGear 1GB switch that is in turned connected to the router. The NUC has a static IP.
When the Roon app on my Pixel 3 states it can’t find the core, I then run a networking tool on the phone and ping the IP of the Rock server and it is successful. So, it’s not a problem with the network itself. The phone can see the NUC’s IP address.

My Android tablet (Android Nougat) has no problems and runs the Roon app perfectly.
I have 2 Windows 10 computers that are running Roon and they both work perfectly with the Core server.

The only problem is with the Pixel 3 and that only started having issues immediately after the upgrade to Android 10.

NUC Rock Core:
Pixel 3:

I think I’ve found the source of the problem with the Pixel 3 running on Android 10 (at least for me).

My Pixel has service with Google Fi - which has a VPN option. When enabled this option sends cellular and WiFi traffic through a VPN. However, it allows local IP traffic to bypass the VPN. In my case 192.168.1.X subnet.
Under Android 10, the Roon app apparently has trouble with this. I found that if I turn off the VPN and run the Roon app it has no problem detecting the Roon Core server. Even if I turn the VPN back on, the Roon app still continues to operate normally. So, maybe the VPN just gets in the way of the initial discovery.
Temporarily turning off the Google Fi VPN is no big deal and is an acceptable work around at this point.

1 Like

Hi @Thomas_Prossima1,

Thanks for the update here and glad to hear you have been able to narrow the issue down to the Google Fi VPN! VPNs can cause traffic shaping in Roon which can be an issue, so I would definitely suggest keeping this off when using the Roon app. Hope you have a continued great Roon experience!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.