Roon app on android disconnects from core

Core Machine (Operating system/System info/Roon build number)
Roon optimzed core kit
Version 1.0 build 227
Roon server software version 1.7 build 667

Roon control via PC windows 7 pro and mobile phone

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ubiquity network
Unify controller/router usg.3p
16port switch
WiFi 3x

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

3x sekret dsm linn hardwired to lan

All equipment has an assigned fixed ip

Description Of Issue

When using roon app on android phone samsung galaxy S10+ the connection to the roon core is lost when the phone goes to dark screen and needs to reconnect.
App has been assigned all authorisation, exempted from slumbering, background data etc allowed

Hello @Hans_Oosterwaal, on the “choose a roon core” screen of the app, there’s a help option that should allow you to enter the core’s IP address. Does this work better?

Hello, I have just also run the updates.
Unfortunately I dont get to chose/set the IP. Its just automatic!
Here below the two screens.

Hello @Hans_Oosterwaal, have you reinstalled the app to see if that brings up the option? It should show up on the “waiting for your roon core” option.

Hi Nuwriy, I have reinstalled the app and indeed it showed up. I entered the IP and it works much faster now. It reconnects within a second. Thanks.

Its not my day :frowning:.

The problem persists, or starts again(?). Every now and then I get connection lost and it takes time again for reconnecting.
I have looked in the help screen and the IP that I entered earlier seems lost.
After filling the IP out in that field again the problem seems gone again.

I had done this yesterday when the problems occurred and today had to do it again when the problems started again.

Hello @Hans_Oosterwaal, do you have better luck if you enter the multicast IP address

I will try this once the problems start again and report back after a day’s trial.

Thanks for helping, Hans.

Sorry to say, I tried the option for 2 days now but everytime the same result as with the IP.

Every day starts with reconnection problems and then I fill out the IP or 255… and for the hours coming it works fine, at least it reconnects immediately (within the time you can say the number 21) when the screen of the phone comes on.

Hi @Hans_Oosterwaal
I never experienced those issues with my Galaxy Note 10+ …?
But, however, I would enable then “keep screen awake” in settings. Hope this helps!

Maybe another Unify Google problem? No problems here with my AVM gear.

Thanks Axel, that will for sure solve it but thats not what I’m looking for. That’s more like solving the consequences instead of the problem.
I don’t think it is Unify nor google (is the last one involved at all?)

Playing spotify directly to the sekrets and all is well.

I understand.
Just in case, did you disable “optimize battery consumption”?

… as for the other question, I took some time to have a look, well …

Ah those google results on android/unify problems. I am aware about those but there I have no problems at all. And we are all on Android here at home (9 devices including 2 TV’s).

Yes on the devices all settings are that the Roon app is excluded from slumbering or whatever power saving features there are, background activity allowed etc etc.

Not that this helps, but I have the exact same issue on a Samsung Note10. As soon as I go onto a different app, say facebook, then go back to Roon, the connection to Roon Core is lost and I get a message “Lost Connection! trying to reconnect” - it drives me mad :frowning_face:

Been through some of these problems in the past, and it does look like some kind of Doze/background task issue.
Not heard too much about Samsung having these issues though. My OnePlus 5 & 6 had them after updating to Android 10. Is there somewhere else in Advanced that this can stopped from being swapped out of memory when not in use?


Taking it out of power management is the only tweak available I think.

Hi Ged, As far as I know the app is out of power management.

Can’t offer any other setting improvements. It works fine on my Android OnePlus 7t but small use to anyone else!

Hans have you looked under Apps (not sure what the setting is on Samsung). But it looks like this on my OnePlus 8



Yes I did Mike, thanks. Its under “energy control --> never sleeping apps”!