Roon App on Core Crashing on Storage Scanning

Core Machine (Operating system/System info/Roon build number)

LENOVO_MFF_ThinkCentre M900
Windows 10 Pro (10.0.19041)
Intel® Core™ i7-6700T CPU / 16GB RAM
Foobar2000 (No problems)
Roon Version 1.7 (Build 667) stable (64 bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ASUS RT-AC68U (Connected with WiFi)
QNAP NAS HS-251+ (Music Storage)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Chord Async USB 44.1kHz-384kHz

Description Of Issue

Hello. First time on the support forum here. Please pardon any amateur mistakes.
I have had this setup running just fine many months now. Then the Roon app* started crashing on Startup around October 20, 2020. It is Crashing after a few minutes of Storage Scanning which is on my Qnap NAS. The PC itself works fine and I can re-open Roon but it will crash again in a few seconds to minutes.

I have done a lot of trial and error with no resolutions. This I have tried are as follows:
(mostly in this order)

  1. NAS: Initially I thought it was my NAS. SO I rebooted it, upgraded F/W and app updates. No change in crashing

  2. Music Files: Looking at the Roon log I found a couple of files which Roon was finding corrupt. I have since removed said files but still no change in condition. Even started with a Fresh DB Rebuild every time.

  3. Lenovo System Updates: I noticed on other articles that it might be the Video Driver needing update. So I proceeded with Lenovo System update to get the driver updates taken care of. There were quite e few to my surprise. Including BIOS. So I did all that. Still no change on Roon crashing.

  4. Display Adapter Settings: I changed the Display > Graphics Settings and set the Roon.exe to use High Performance (GPU Intel® HD Graphics 530. Rebooted. Still No change.

  5. Windows Update (2004). I saw articles where the Windows 10, 2004 update was causing problems with Roon. Unfortunately I was not able to rollback with system restore but I Uninstalled all the recent updates in October 2020 and disabled Windows updates for the time being.

  6. .Net Errors in Event Viewer: Went away after I removed the latest .net update from MS. Still crashing though.

Application: Roon.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an internal error in the .NET Runtime at IP 745F98CE (742E0000) with exit code 80131506.

  1. Roon: Needless to say, I have uninstalled and re-installed Roon multiple times in-between. I have even tried the 32 bit version with a fresh database every time. still no change.

Interestingly, if I DISABLE the Storage Scan then Roon stays up no problem. Although that is certainly not the solution. Other apps like Foobar2000 have no problems playing the same audio files and such.

Any help is much appreciated. :pray:

1 Like

What are the arrangements for cooling on that machine?
Is your music folder split into sub-folders? If it is can you point Roon at those sub folders in turn?

Good question. I should specify that it is just the Roon App that is crashing.
Not the Machine itself. The PC stays ON on a daily basis and runs cool.

Music folder is split into 20 Genre sub-folders. I can give that a try here and report back

You could create a folder and point Roon at it then move sub-folders in one at a time.

I tried to add the sub-folders one at a time as you had suggested .
Worked good for 7 Folders straight which was encouraging.

Then I added folder #7. It stated syncing a few songs … and then it crashed.
Now Roon crashes within 10 seconds of starting up. After a few tries I was able to speed up to the part where I can Disable the last folder added. Assuming that it might be the cause for this particular “crash loop”. After 8 tries I was able to Disable it. But it still crashes after 10 seconds or so.

I guess I can work thru it again to remove the folders one at a time or simply uninstall and start with new DB. Interestingly no crash reports on Event viewer.

time to get some logs sent in I think

It does look potentially like something in that 7th folder is causing Roon to crash unless it is pure coincidence. Hopefully support will be able to identify the offending file(s).

How many files are we talking about in this library?

Folders 1 - 6 > 1.10 TB (27,517 Files / 2822 Folders) Enabled on Roon and Syncing

Folder 7 (HDX) > 650 GB (18,555 Files / 1692 Folders) Disabled but not Removed*
*Will attempt to remove this in the 10 Seconds before Roon crash loop

Folder 8 - 20 > 2.44 TB (56,423 Files / 4989 Folders) PENDING. Not Added to Roon

Too much?!? It was working fine till last month with just the Music Files Parent folder added.

I’ve had an instance where a file in my music library would crack the server.

Logs will help find it, and I’m sure the @support guys will get it figured out.

Hi @Robert_Horowitz,

Can you please use these instructions to send me a set of your Roon logs for review?

Thank you for your suggestions everyone. Spent days trying different things!

@noris Roon (Core) Logs available HERE

1 Like

Thanks for sending those logs over @Robert_Horowitz, I believe I found the file with the issue:
M:\MUSIC FILES\BLUES\Chess Blues\100 Sitting Here Alone.m4a

Can you please move this file out of your watched storage locations, restart the Roon app and see if that resolves the issue? If it does, please do not delete the file as it would be useful for QA purposes.

Done. Said file is moved out of the entire folder structure.

Still crashing right away unfortunately.

Updated logs#2 Here

1 Like

Any further thoughts on this? @noris

1 Like

Hi @Robert_Horowitz,

Thanks for your patience while your case reached my queue again.

I am looking over the log and I see Roon stuck on a file in the same folder:
M:\MUSIC FILES\BLUES\Chess Blues\34 Don't Need No Horse.m4a

Can you please try to exclude the entire Chess Blues directory and see if this stops the crashing?

Please do not delete these files yet, because if they stop the issue when excluded, I would kindly like to request them for QA purposes.

Thank you for keeping me in queue

Moved the folder out. Still crashing unfortunately.

Cannot post link to new log for some reason. (cannot post link to this host)

Hi Robert and @noris,

The Forum software spam controls have stopped Robert as a new user repeatedly linking to Google Drive. I have upped Robert to basic user, which may solve the issue.

Noris will let us know if he needs the logs or can see them by enabling diagnostics. If the logs are needed and Robert is still unable to link then it may be possible to PM a link rather than make a public post.

Admins might also consider adding Google Drive as an allowed link for new users.

Apologies for the inconvenience Robert.

Thank you @andybob for moderating :relieved:

Will stay tuned as they say …

LOGS SHOULD ALWAYS BE SENT IN A PRIVATE POST

and yes I am shouting this.