Roon app on iPhone (iOS 13.1.2) crashes

That’s a shame! I was expecting maybe the rewrote the ios app without all those memory leaks.

Yeah me too…

I have been having the same issues with Roon since 2019 when you posted this. It works on my iPad 98% of the time with no crashes. I’m using iPhone 12 OS 14.2.2 with latest Roon on core an app on phone. Today it started crashing 10-15 sec after choosing a song.

I had this same thing, it’s been pretty stable generally but today it started crashed repeatedly. Uninstalling the Roon app, turning off the phone, then turning back on and reinstalling seems to have sorted it out (until the next time it starts happening). Good luck!

1 Like

I’ve had this issue forever with my iPhone X as well.
All software is current on phone and roon nucleus.
iPad works great.
It is maddening.
Does Roon need more people to share our info?
If so, I’m happy to.
I’ve tried fixes mentioned in this thread and nothing helps.

This is the thread discussing the issue: iOS devices crashing on 1.8 [Roon Investigating]

The issue has not changed from previous versions of Roon (at least 1.7, maybe even further behind). It seems to me there is either a memory leak or poor memory management and it seems to me that iOS is killing the Roon app on the iPhone because of this. The iPhone app GUI is not the same as the iPad one, and if I had to guess, it would be that the memory issues happen in the GUI component. The fact that this has not been solved over what seems like two years now is mind-boggling to be honest.

2 Likes

Thanks for the update. This is indeed brutal.
Sounds like there’s little hope.
It’s odd that this isn’t more widespread, I wonder what the determining factor is for those of us afflicted.

I use a TON of iOS apps. Very few have ever had a crash issue like this, none where it had not been resolved.

From logs various people have posted, the following seems clear:

1- It is iOS killing the Roon app purposefully because some limit (likely memory) has been breached

2- It does not seem to happen on the iPadOS version: It has never happened to me there thus far but the app has at times crashed. But it is very rare, almost never in mid-use, and it is not as forceful and consistent as when the iOS app starts to crash

So from this evidence I gather it is an issue, likely a memory leak, in the branch of the code that handles the iOS GUI.

What is puzzling to me is how come this has not been resolved yet. Has Apple been asked to help profile the issue? Surely you must see a memory leak in a simulator. I don’t understand how this is not resolved!

3 Likes

A hundred times this. :+1:
No other app died like Roon Remote. And certainly no other thereafter continues to crash after 20 seconds until the iPhone is restarted.

This is very sad - even now on iOS 14.5.1 and iPhone 12 Pro the consistent crash is back with the latest app version :frowning:

Here is temporary fix

Press the Volume up quickly let go
Press the volume down quickly let go

Hold power button till prompt restart

This is a harsh solution. Basically cold boots the phone without a proper shutdown. Not recommended.

But this also points to mem leaks as the mem caches between sessions gets cleared.

3 Likes

If had to take a wild guess, it would be that the failure is in the management of image caches. It seems to be the case that a cleared cache allows the app to work until the cache fills up again.

It would also be nice if somehow we knew that the Roon dev team cares!

2 Likes

Still interested in any theories why this only seem to affect a small nubber of users? Conflicting app? Language settings? VPN’ stuff?
I don’t see these crashes, and i use three iPhones and two iPads regularly.

Again just another crash. This is a continuous experience stretching over different iPhones (XR, 12pro). No VPN tools, always latest iOS. Different Roon versions - always the same annoyance.

Also I almost gave up. My Roon renewal is paused and I am determined to let it phase out, as to what I perceive Roon is either not willing, not capable or simply not interested to solve this. There are simply no excuses, as this is happening for so long and has been reported to support ever since.

1 Like

What type of WLAN are you on, and do you have any special network settings? There must be something that differs from the majority of users. What image cache is set in the client and what size of library?

Nothing offbeat, all standard. Streaming only and just a couple of hundred albums. All set to English which promised to solve some other hickup. Every setting either standard or conservative. Removed and reinstalled more often than I breathe on a normal day. WLAN is AVM’s Fritz stuff, series 3000 and now also 6000 - all APs hooked to the central Zyxel switch by ethernet. That will lead just nowhere.

The iPhone is used as a remote only and the Roon app fails more miserably than ANY OTHER app ever did. Once it dies it continues to do so until you restart the friggin device.

Honestly, given this I won’t regret too much to let Roon go, although I like it when(!) it works.

1 Like

Given that the experience on the iPad is much different, I don’t see how networking can possibly matter. It is also an issue that does not always happen but when it starts happening it happens always. My library is about 16k albums. Image cache is the default in both iPad and iPhone cases.

1 Like

I believe the issue is in the “retina” resolution. When it’s 2x it’s working fine, but the “super retina” devices are effected (my XS, the X, 11, 12…).

I’ve been having this issue for a loooooong time, and it starts when browsing through a lot of albums, pages, etc.