Roon app on iPhone (iOS 13.1.2) crashes

It happens to me, all the time. Here’s a console log:

default	10:02:05.712961 -0400	ReportCrash	Process RoonMobile [5206] killed by jetsam reason per-process-limit
default	10:02:05.715867 -0400	ReportCrash	starting prolongation transaction timer
default	10:02:05.740818 -0400	ReportCrash	Launched ReportCrash to service - com.apple.ReportCrash
default	10:02:05.740895 -0400	ReportCrash	Trying to create CR directory structure as root
default	10:02:05.759732 -0400	ReportCrash	cr_update: Parsing corpse data for pid 5206
default	10:02:05.759908 -0400	ReportCrash	cr_update: Parsing corpse data for process RoonMobile [pid 5206]
default	10:02:05.779410 -0400	ReportCrash	__crash_info: [<private>] '(null)'
default	10:02:05.803025 -0400	ReportCrash	Report of type '298(298)' not saved because the limit of 25 logs has been reached
default	10:02:06.016545 -0400	ReportCrash	Formulating fatal report for corpse[5206] RoonMobile
default	10:02:06.032111 -0400	ReportCrash	report not saved because it is non-actionable (ie: extension hangs or internal-only)
default	10:02:15.749751 -0400	ReportCrash	ReportCrash is exiting
default	10:02:25.717701 -0400	ReportCrash	releasing expired transaction
1 Like

My iPad has just received an update to 3.1.3. It was unaffected by the problem but it would be interesting to see if it has any impact on those it did affect. If the problem persists perhaps an exact phone model of those affected might help narrow this down.

Assuming you mean 13.1.3
iPadOS 13.1.3 has been available for a while now. Are you saying that you had 13.1.3 and have now been updated to a newer version of 13.1.3?

I did mean 13.1.3. I don’t go chasing updates. I wait until the device informs me it is available. This thread mentions 13.1.2 in the title, are you confirming the issue remains with 13.1.3?

Apologies for the confusion. I’ve followed this thread with interest despite the fact that I’ve not personally had any issues with either 13.1.2 or 13.1.3 on my my devices.
iPhone 11 Pro
iPad Pro 10”

1 Like

A post was split to a new topic: iOS app closing after 15 seconds

I have had the same cycle happen to me - the iOS app becomes unstable and crashes soon after opening, repeatedly. In other instances it takes a bit longer.

My setup: iPhone XS Max / iOS 13.1.3 (same happened in 13.1.1 and 13.1.2). Also running iPad Pro with iPadOS 13.1.3 and it is very stable, no issues.

I tried deleting the app, restarted phone, and reinstall - no dice, still crashes.

Everything works fine on my iPhone since 13.1.3 :wink:

A post was split to a new topic: iPhone XS Max crash

Hello All,

Last night Apple released iOS 13.2. For those affected by this issue, can you please let me know if there has been any change since upgrading to iOS 13.2 or if the behavior is still the same? Thanks!

A post was split to a new topic: iOS app crashing on genre selection

Actually it is looking pretty stable right now!

1 Like

A post was split to a new topic: iPhone X crashing on 13.2

A post was split to a new topic: iPhone 11 on iOS 13.2 crashing

Take this back. As before, once it starts crashing it becomes very fragile. On iOS 13.2. IPadOS is pretty stable.

Yeah, I try to use my phone every evening, and eventually want to throw it at the floor.

I can reproduce this at will, and as I can get logs off the device (see 30 days ago) I’d like to help solve this.

Today, I just avoid playing music, which is about the saddest thing I could possibly say.

Sad, and frustrated. And really regretting the last subscription renewal.

HI @miguelito / @Steve_Kalkwarf,

Apologies for the frustration here. Apple recently fixed an issue in 13.2.2 which caused apps to crash unexpectedly, and today released iOS 13.2.3. Can you confirm if iOS 13.2.3 helped with Roon crashes on your end?

Release notes for iOS 13.2.2:

iOS 13.2.2 includes bug fixes and improvements for your iPhone. This update:

  • Fixes an issue that could cause apps to quit unexpectedly when running in the background

I already updated to 13.2.3. I’ll post what I observe after a few days.

13.2.2 was still crashy.

Since installing 13.2.3 on about four days ago, it has been stable.

I’ll report back if/when the problem reoccurs.

2 Likes

No crash since iOS 13.2.3. Seems to be solved now. Thanks!

1 Like