Roon App Randomly Crashing - Have to relogin [Solved - Emptied NAS Recycle]

See below for original problems. System remain same (except for the reglar updates of borh OS and Roon - and JRiver).except I now use the new MSB renderer2

So, what’s happening is that Roon is again constantly crashing - never anymore than a couple of tracks- whereas JRiver is rock solid. And when I restart Roon, most times I have to relogin.

Hi. I am a new Roon user, still in the trial phase, basically testing whether to change over to Roon from my long-term JRiver system.

For the past 5 years I’ve used JRiver, on a computer extensively modified to extract maximum goodness for my bits: fanless i7 Haswell with 16Gb DDR, running Windows Server 2012 R2 with AudioOptimiser and JPlay; and separate isolated battery power for motherboard, JCat USB card, and 3 x SSD. The music is on 3 drives: 2 internal 500 gig SSD’s and one external WD 3Tb NAS connected directly by ethernet cable to the computer.

When I initially tried to install Roon, having backed out of Audio Optimiser as far as possible, I had problems with video drivers (I’m using the built-in video, not an external graphics card) – what I gather are the usual OpenGL issues. I solved this by finding a new video driver online, and after that Roon seemed to work – though it struggled with initialising the database – I have over 50,000 tracks.

My DAC is an MSB Technologies Reference DAC, with the MQA enabled Quad USB input module connected to my JCat USB card.

Currently I boot into Windows Explorer, from which I can select either JRiver, Roon or the Tidal app. JRiver connects to the DAC through the JPlay Kernel driver. I disabled all the possibilities on Roon except for the MSB ASIO driver.

My problem is that Roon keeps crashing. Whereas JRiver is completely stable, Roon will only play for between 30 seconds and 10 minutes before it closes down. It’s not that the computer shuts down, just the Roon app. And it’s very slow to open – at least a minute.

I did notice that, although I’m getting the purple seal of approval, when I’m playing Hi-Rez PCM the front of the DAC shows the bit depth varying between 20 bits and 24 bits, which it never does with JRiver.

I would like to stick with Roon – it’s got much better metadata than JRiver, I like the integrated Tidal streaming, all and the SQ seems to have improved markedly from when I first tried it 2 years ago, but I need to track down this problem.

Any thoughts?

Tagging @support for you here.

Hello @Graham_Thorburn1,

Thanks for contacting support regarding this issue and for posting your description here. I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

I kindly ask for you to note the exact local time of the next crash (ex:11:11PM) and let me know this information. We will then cross-reference the diagnostics received to see if there are any errors being outputted around that time.


Hello @Graham_Thorburn1,

We have received the diagnostics from your machine and have taken a look at them. The QA team has noted that you are likely seeing a permissions issue here with regard to the crashes. It is possible that something is preventing the file system from writing to the database, such as mounting the Roon database location as a read-only path. I would suggest the following:

  • Verify that you can write files using the same account to Roon’s Database Location
  • Check to see if you have enough free hard drive space where Roon’s database is stored
  • Verify if you have enough free RAM on your Core
  • Take a look at the permissions for the Roon Database folder, does it have read/write permissions?
  • Have you made any changes to the Roon shortcut “Security” properties?

Please let me know if these suggestions help.


Problem seemingly fixed - I emptied the recycle bin on the NAS drive and things seem to be OK again. However, I couldn’t find the Roon database using the %localappdatta% - for future reference any other ways to find it in a Windows environment?

Hello @Graham_Thorburn1,

Glad to hear that the issue has been resolved!

The %localappdata% should work but if not you can navigate to it though C: -> Users -> Your_User_Name -> AppData -> Local -> Roon. You should not touch this folder unless directed by support staff though as any changes made to it can affect your Roon database. The path you can post in Windows Explorer is this: C:\Users\USERNAME\AppData\Local.

Either way, glad that the issue has been sorted out and do let us know if we can assist in the future!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.