Roon App won't launch on my iMac pro

Core Machine (Operating system/System info/Roon build number)
iMac pro running High Sierra 10.13.6

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
My internet provider is Spectrum.
Motorola Surfboard modem.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Myth Brooklyn Bridge

Description Of Issue
My Roon app will not launch, it stopped working after a week of enjoying your trial period. In fact, I am out of the trial period and have paid for my first year.

I tried re-downloading the app only to have the same issue-- will not launch. I thought I read somewhere that Roon labs were experiencing problems/ server issues. Is this still true?

I really enjoyed that first week of Roon and now that I am a paying customer please advise.

Try renaming the User > Library > Roon folder and relaunching.

Hello @Octavio_Molina,

I suggest you perform a reinstall of Roon as @MJB noted, here are expanded instructions:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

Do let us know if this helps!

thank you. renaming folder worked-- issue resolved!

1 Like

That’s fantastic news @Octavio_Molina do let us know if you have any other difficulties!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.