Roon appliance consumes all resources on server and needs to be restarted

Roon Core Machine

Windows 11, 16GB Core i7-4770

Networking Gear & Setup Details

Roon server is wired, so are main players.(Asus zenwifi and smart switches)

Connected Audio Devices

Auralic altair, chromecast, sonos and a few raspberry pi running raat.
Connected to home assistant

Number of Tracks in Library

6029 tracks

Description of Issue

I run roon server on my windows 11 server (normal windows 11 install). After playing an hour or so on my auralic altair roon appliance generally consumes as much resources as it can leaving the system sluggish and playback starts to skip and finally stops. Restarting roon server resolves the issue.
I also had this problem on my old windows 2016 server and decided to move it to a more powerful machine as I thought it was getting old. Same behavior there as well.
There seems to be some sort of memory leak that makes roon unusable for me.
As an example, I restarted roon server. It now has a commit size of 400mb and working set is roughly the same. Before I restarted roon appliance had a commit size of 10GB!! Also, it seems roon tries to access most of it as the working set is of similar size consuming all physical memory.
On my previous server this caused 4000 hard page faults/sec as it did not have the memory to cope.

Edit: Example after restart 3 hours ago with constant streaming:


I am having a similar /related problem. I run Roon on a dedicate Mac mini ( 2011) without problems until recently. Now however almost every day I "lose " Roon and on investigation find that the App has shut down on this machine working as the server - with an error message on the Mac saying that there was insufficient memory - It has 8g with no other apps running.

After 24 hrs:

How does roon support work, is it all public? This puts me in an unusable state, or restart every few hours.

@Torko @Marc_Gillespie from what I’ve read here, it seems that the development team is already working hard on these issues. I think they only need more individual notes if other problems than these arise. One team member even posted that he will give an update on the status of the work in 24 hours at the latest.

Support is after reorg in a better position now and is more expeditious in picking up on issues that are reported. If the problems are the same, it is more efficient not to repeat again everything that has already been mentioned as intermediate solutions.

Maybe there will be a direct feedback from the team side today or tomorrow. The work will be done after receiving the reports and when the final solution is foreseeable, the success will be reported.

A little patience and a lot of reading in the meantime will relieve the team. Thanks for this.

1 Like

Also (I kind of hesitate to link to this somewhat charged thread):


Thanks for all the replies, I did some searches before posting, finding that the issues seem related to Linux builds, thus creating another one as this is on windows. It can definitely be related depending on how it is built.

1 Like

It would have been nice to receive some sort of acknowledgement from Roon that the issue is received, and potentially link it to the other issue if that is believed to be the same.

1 Like

Hi @Torko,

Thank you for reaching out about this issue and I’m sorry to hear you’ve been experiencing issues for several days.

The symptoms you’ve described are consistent with one of two known memory leaks the team has fixed with the most recent build. Please see the release notes for Build 970 here for additional details.

Updating to Build 970 should resolve these issues across all platforms and devices. This topic will auto-close, but if you continue to experience any issues, please reach out in a new topic thread and the team will support you.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.