Roon application not responding on Macbook

I updated to the new server and can now connect to the core using the Roon Remote software on both my iPad and iPhone.

However if I use the Roon app on my MadBook, the app will go into “application not responding”. I have installed the latest version of Roon manually, rebooted etc etc but still have the same issue. Any ideas ?

Hi @Chris_Farnell ,

Can you please provide the following information so that we can better assist you? Thanks!

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

1 Like

Hi @nories

Roon Core Machine

Core is running on MacMini (late 2012), 2.3GHz Intel, 4G RAM, macOS Mojave. Running Roon Server (latest build)

Roon application that not responding is on MacBook Pro (2019), 2.3GH Intel, 16GRAM, macOS Monterey.

Networking Gear & Setup Details

MacMini connected via Ethernet, MacBook on WiFi (Netgear)

Connected Audio Devices

Main Roon Endpoint is Oppo 205

Number of Tracks in Library


Description of Issue

After updating to latest Roon release to resolve issue with Core stuck on initialising, the Roon Remote applications on iPad and iPhone all work perfectly, but the Roon app on my MacBook opens and then gets stuck in “application not responding” (blank screen in Roon app - see below). initially thought due to slow response on MacMini and due to library updating, but left running overnight and still same.

Tried downloading latest Roon app manually from website and installing, but still same issue.


Add images

A post was merged into an existing topic: Roon vs RoonServer database on same PC

I guess it possibly you do have both roon server, and the combined roon server/ client running.

There is some info about switching here:,that%20is%20used%20for%20Roon.

Before you do anything, make sure you have a backup of the ‘good’ library!

Hey @Chris_Farnell,

A good thing to note here is that you’re only able to access one core per roon license. If you’re trying to use 2 cores for your account, you’ll need to unauthorized one of the cores before attempting to access the other.

If you are looking to use your Macbook Pro as a core, be sure to unauthorize your MacMini first.

Let me know if your issue persists after the above :+1:

Hi @benjamin,

Thanks for the response. I only have the core running (via Roon Server) on my Mac Mini and have never setup as a core on my MacBook - it’s purely used as a client to play my library when i’m working on the computer.

Additionally, the MacMini only has Roon Server installed - there is no Roon Client running on that.

As mentioned in my initial post, the clients running on both my iPad and iPhone are both working perfectly after the Roon Server update, it’s just the client on the MacBook that hangs.

1 Like

Hey @Chris_Farnell,

Thanks for the info! In the case of using your Macbook only as a remote, please fully uninstall Roon, give the computer a hard reboot, and reinstall Roon. Let me know if you still have this issue after the reinstall :+1:

Hi @benjamin,

I have tried to uninstall / reinstall a couple of times, both with no success…. Dragged the current Roon app to the trash and reinstalled using the version downloaded from the Roon website.

I know that dragging the app to the trash may not always fully uninstall, so is there anything else I need to delete to do that ?

You’ll need to empty the trash bin to complete the process, but once the app is in trash it’s no longer present from a functional perspective (at least that’s the theory).

That leaves configuration files and directories created by the app behind. To get rid of all app-related files and directories, you can use the little free (as in beer) utility AppCleaner.

Hi @benjamin,

I have tried an uninstall and reinstall again with a reboot of the MacBook after trashing the original app.

Still have the same issue - Roon will launch, but then present me with a blank screen and the spinning beachball with “application not responding”

One thing I have noticed though is that on initial launch the app does show the current track playing on Roon (which is being controlled from my iPad) and so it is communicating with the Core okay. I note that this does appear to be a “snapshot” as the track time does not update (i.e. the app immediately stops responding). See below screenshot…

Hey @Chris_Farnell,

When uninstalling, you’ll need to do the following on top of removing the Roon application icon:

The databases, settings, and artwork live in the /Users/USERNAME/Library/Roon folder.

To get there:

  1. Open Finder and click Go in the top bar
  2. Hold down the Alt key to unhide the Library folder
  3. Click the Library folder
  4. Find and delete (or rename) the Roon folder

Depending on how you configured Roon, there might also be a /Users/USERNAME/Music/Roon folder.

If you delete those folders you should be all set for a clean install!


Hi @benjamin

That worked perfectly. Roon player now up and running on my MacBook.

Thanks for all the help.



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.