Roon Arc and Port Forwarding Problem with Netgear router

Roon Core Machine

MacBook Pro (Retina, 15-inch, Late 2013)
Processor: 2.6 GHz Quad-Core Intel Core i7
Memory: 16 GB 1600 MHz DDR3
MacOS: BigSur

Same problem also occuring with:
MacBook Pro (16-inch, 2021)
Processor: Chip Apple M1 Pro
Memory: 32 GB
MacOS: Monterey

Networking Gear & Setup Details

  1. Who is your internet service provider?

Connection from China, but not using a public provider

  1. Please list the make and model of your modem and router?

Netgear Nighthawk X6 R8000
Connected through WiFi with a fix IP address

  1. Do you have any additional network hardware, like additional routers or managed switches?

  2. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Not that i am aware of.

Connected Audio Devices

Currently no audio devices are connected since I am setting up a new Roon core in a new computer to get Roon 2.0 and ARC working. Previous computer running Roon 1.8 cannot be updated to Roon 2.0

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

From reading other similar support messages, I am aware that this error could indicate a problem with UPnP. So, I went ahead and already setup manually port forwarding for Roon, but still get exactly the same message. UPnP is however working for other devices, so there might be a real issue here with Roon.

After manually setting the port forwarding, I checked the port using this link: Open Port Check Tool - Test Port Forwarding on Your Router
and got the message that the port was closed.

I did double check if i followed properly the instructions to manually setup port forwarding in my router, and i believe i did. There are a couple of suggested youtube videos in other threads and it is exactly my router and procedure: Port Forwarding NETNEAR Nighthawk - YouTube

Do you have other suggestions for what to try next?

Thank you

Should I have any hope someone will eventually reply to this?

The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Hello Joao.
Welcome to the forums.
Sorry that your first experience here resulted in a longer than typical delay.
Roon support monitors this forum and will respond but they have been busier than usual lately so it can sometimes take a week or more.
In the meantime other Roon users are often able to solve many issues.

Unfortunately I’m not that user as my networking knowledge is limited.
What I can tell you though is that I have a modem set to bridge mode and UPnP enabled on my router.
Using the port check tool you provided I see the port ARC is using as being open.
So it would appear, in your case, either UPnP or port forwarding isn’t correctly configured.
You might double check UPnP is enabled or that you’ve used the correct IP address and port number in your Port Forward rules.
And it’s always a good idea to restart everything in this order: Modem, router, Core - waiting for each device to boot up before powering on the next one.