Roon ARC cannot access my Core

Roon Core Machine

Antipodes K50

Networking Gear & Setup Details

Orbi R850 w/ one satellite

Connected Audio Devices

Linn Klimax DSM connected to K50 via ethernet, Trinnov Amethyst connected via ethernet

Number of Tracks in Library

34,738 tracks

Description of Issue

Auto config did not work on ARC. I have set up my K50 with a static IP address and port forwarding using your instructions and it still can’t connect. Here’s the error code -
{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH 97.115.225.234:55002, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“97.115.225.234”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}
}

Thanks for your help

Hi Chris,

Can you provide the following details about your network setup to help expedite troubleshooting?

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  5. What machine are you using as a Roon Core, and how is it connected to the internet?

Thanks!

  1. Who is your internet service provider? CenturyLink
  2. Please list the make and model of your modem and router? modem: Zyxel C3000Z, Router: Orbi RBR850
  3. Do you have any additional network hardware, like additional routers or managed switches? My core is connected to an Orbi satellite. No managed switches, but I do have a Melco S100 switch connected to the Orbi satellite
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security? Nope
  5. What machine are you using as a Roon Core, and how is it connected to the internet? **My core is on an Antipodes K50 and it is connected via ethernet to the Melco S100 **
    Orbi Satellite → Melco S100 → Antipodes K50

So you have a potential double Nat, one router behind another, issue. Can you set one of them to be in bridge mode?

1 Like

The satellite is not another router, it is a four port switch. The Orbi router is connected to my modem

This FAQ might help

Thanks - I followed those instructions before posting here.

Is the Zyxel C3000Z in bridge mode? If not you have 2 routers and thus a double NAT.

I think that’s the issue. I’ll look into this. Thanks