Roon Arc cannot connect to Roon Core (FirstMedia)


I am getting the error below when I am trying to connect to roon arc to roon core:

“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nPAL_UPNP_SOAP_E_ACTION_FAILED\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}

I am using linksys velop as the router and roon core is installed in a QNAP NAS.

Hi Rohit,

I am moving this to Support section. In addition, can you specify the ISP you use, and any other networking equipment. This will help support help you.



My ISP is FirstMedia in Jakarta, Indonesia. Wireless Router is Linksys Velop and Roon Server is installed in QNAP NAS 253D 4G 2 Bay. The external ip displayed above is actually the external IP defined for the QNAP NAS to access it using myqnap cloud link and not the external ip for the router.

Hi @Rohit_Chaudhury,

Thank you for your endless patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that your Core is having difficulty reaching our servers in addition to reaching your mobile device via the port forward rule. It’s also possible that UPnP is misconfigured in the Linksys settings.

There are several independent factors that can cause this error, so we recommend double-checking the following to initiate troubleshooting:

  1. Is your router firmware up to date?
  2. Do you have any VPNs, proxy servers, or enterprise-grade security on this network?
  3. Are you experiencing any issues with Roon Remotes, or other apps on your local network?

If you continue to experience difficulties, please tag the support team and include the following information:

  1. Do you have an additional modem/router or gateway in this setup, or is it a one-router setup?
  2. If so, is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?
  3. Have you enabled UPnP on your router?
  4. Have you experienced any issues with QFirewall, and have you set exceptions for Roon?

Additionally, you can pass along some questions to FirstMedia’s support department to illuminate whether they have network address translation preventing your connection:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.