Roon ARC connection fail

Roon Core Machine

Roon ARC was unable to access my Roon core.

Networking Gear & Setup Details

Linksys MX5300

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Roon ARC is not able to access my roon core, with error below:
{
“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“42.aaa.bbb.ccc”,“router_external_ip”:“42.aaa.bbb.ccc”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true}
}

Hi Hung,

The Timeout error indicates that the core is having issues reaching Roon’s servers and is timing out waiting for a response.

Have you tried rebooting your network?

After rebooting, the error has changed to:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 116.ddd.eee.fff:40817, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“116.ddd.eee.fff”,“router_external_ip”:“116.ddd.eee.fff”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true}
}

The new diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?
1 Like

Hey @Hung_Chan,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, I wanted to check in to see if you were still running into issues getting Arc squared away? If yes, then please provide the information @Martin_Webster has asked in the previous post.

I’ll be on standby for your reply :+1: