Roon Arc connection failure

Roon Core Machine

I am new at this an not a very advanced user.
I installed roon with the core in my Macmini m1, 16GB RAM)

Networking Gear & Setup Details

My ISP has a ZNE router with very limited setup options.
I have a second router, an AX1800 TP-Link router connected to the ISP modem by cable.
This secondary router is the beginning of all my network connections. My Roon core is connected to the AX1800 by Wifi (very close to the router, cable connection is not possible atm).
I use and stream ROON and TIDAL no problem on my Macmini (the setup of it will be a second question that I will post in another message).

Description of Issue

My current issue is the following, when I check the Roon ARC I get an error:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“187.aaa.bbb.ccc”,“router_external_ip”:“192.168.1.3”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true}
}

I cannot set my ISP router as bridge because they don’t have that service. They don’t have available Static IPs or Dynamic IPs at the moment, their only option is a “NATed IP”.

The troubleshooting page suggests
(1) Setting the ISP modem in bridge mode. This is not possible.
(2) Set my second router in Bridge Mode, this I don’t know how to do. I tried deactivating NAT on my second router and all the devices connected to it lost their internet connection.
(3) It suggests to ensure port forwarding rules, but that is beyond my knowledge of the matter. I started to implement a simple DMZ forwarding but the Troubleshooting page warns about that solution (not that I made it work).

Hey @Ricardo_Garcia_Maino,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest there is a redundant layer of network address translation preventing port forwarding.

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

If your setup involves an ISP-provided gateway (modem/router combination) and your own third-party router:

  • In the web administration interface of the ISP-provided gateway (modem/router combination), enable Bridge Mode or equivalent, where the ISP-provided gateway does not have DHCP routing enabled.

  • Alternatively, if you have already created a manual port forwarding rule in your 3rd party router, you can add an additional rule to forward the port through the ISP/second router.

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

If you’re unable to locate an existing solution in our #support:port-forwarding-resources subcategory, please reach out to the Roon support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?