Roon ARC connection issues

Roon Core Machine

Apple MacNini, i5, 16 GB

Networking Gear & Setup Details

Netgear Orbi RBRE960

Connected Audio Devices

AVM Ovation CS 8.3emphasized text

Number of Tracks in Library

Description of Issue

Roon ARC cannot connect:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

@Stephan_Burman, welcome to the Community. A fellow user here, the diagnostics you’ve provided suggest that UPnP is enabled on your network, but your router is refusing the connection. This is either the result of UPnP not being enabled properly on your router, or settings at the level of your internet service provider.

First, to confirm the issue is not with your local network setup:

Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
Try to manually open the port in your router’s port forwarding configuration
Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
Check for any VPNs or Firewalls that might be interfering
Check if your modem is in Bridge mode

If you continue to experience difficulties, we recommend reaching out to your internet service provider and passing along the following questions:

Have you implemented carrier-grade NAT for my account level?
Have you fully implemented IPv6, or do you have IPv4 addresses available?
Can I request a static IPv4 address to support port forwarding?
Are there any ports you have reserved at the ISP level I should be aware of?

Hi @Stephan_Burman,

I would suggest you try to do a manual port forwarding.

First in the roon app under Settings → Roon Arc write down the ip address and port number shown there.

Watch below video (maybe not your exact model but hope it’s enough).

Hope it helps.



This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.