Roon Arc connection problem through BT Home Hub 5 router and Google Mesh wifi Hub to Roon Nucleus

Hi there,
sorry … another connection problem with the Roon Arc app, I think the idea is fantastic though!

My ISP is BT (British Telecom), which from what I have read don’t allocate fixed IP addresses.
I have a BT Home Hub router, I’ve had a look through the setting and it doesn’t appear to support Bridging and seems to have limited options for setting up port forwarding.
Internally, the router is on
The router is connected by wire to a Google Mesh wifi hub, I have the Mesh wifi throughout my home with many devices attached by wifi and some by network cable including a Roon Nucleus.
This network is on a different IP range but it has the BT router setup as the WAN address, so I guess the Mesh wifi hub just passes all internet traffic through it to the BT router.
I can setup port forwarding on the Google Mesh but as far as I can see this wouldn’t help as the Nucleus already communicates very well with the Mesh hub.

As far as I understand, somehow I need to open the path between the Nucleus through the Google Mesh wifi hub to the BT router and then get the BT router to open the ports to the outside world?

This is the connection error I get from Roon Arc…
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:“yyyy”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I could contact BT to try and get a more up-to-date hub but I don’t think their newer ones support bridging but they might support better port forwarding.

I would still need to enable the forwarding between
Google Mesh wifi hub
BT Router
outside world dynamic IP address and the Roon Arc app

Am I asking too much!


So if you have a Homehub that is acting as the router as this can’t be turned off, your mesh it just hanging off the router and you could actually turn wifi off in the home hub
You need to log onto the home hub, go to advanced and select port forwarding.
Identify the IP address of your roon core and set up a port forward so traffic can pass to that IP on the Roon port.

So in the screenshot below, I call the forward “Roon-ARC” so I know what its used from
Replace “RyanNAS” with the IP address of your core or its name if you have named it in the Homehub.

Hi Phil,
Thanks for coming back to me. The reason I have the Google Mesh Wi-Fi hub is to extend my Wi-Fi through the house with a number of connected Google Mesh Wi-Fi hubs. I checked these and they are operating in bridge mode.
So it’s really the other way round, I have an extended Mesh Wi-Fi with a BT home hub hanging off it to provide internet access.

No you don’t, the google mesh is in Bridged mode meaning it is not performing any routing.
If you log onto the home hub and go to the “my network” tab you will see a list of all the IP’s on your network, you can see on mine I have wi-fi turned off as Wi-Fi is supplied by two BT Whole Home mesh disc’s.

The only way you can have another router on BT Broadband is to replace the Home Hub with an Openreach modem.

So the result is the same set up a port forward on your Home hub.

As above.

Port Forward under advanced settings.

Those white open reach modem boxes are very sort after.

Sorry Phil, I think I might be confusing my self here!

So my main Wi-Fi is setup with a Google Hub, I think the main Google hub is acting as a router, it says it’s in NAT mode.
Strung off this Wi-Fi are other Google extenders set to Bridged mode.

Are you suggesting I try and turn the Router off on the main Google Wi-Fi Hub?

The BT home hub is connected by wire to the main Google Hub, I don’t have the BT disc Wi-Fi extenders.

Sounds like I might need to upgrade my network!

I don’t know anything about the google mesh to offer any advise on its config.
But if you have a standard phone line with a home hub plugged in you must have FTTC.
You maybe doing a double NAT, but I don’t know.
I would see what the IP address is of your core and see if that’s on your home hub, if that’s the case setup a port forward on the home hub.

The other option to port forward is to use Tailscale as a number of us have done which is a vpn type access rather than a port forward, this needs a basic skill level to understand.

Just checking in more detail
Google Nest Hub, appears to be set to router and NAT on network

  • Google Nest wifi extenders acting in Bridged mode

BT Home Hub

  • also seems to be acting as a router but on IP network … I’ve just tried to change this to but BT wont allow me to do this.

so I seem to have two network ranges and with a router on each!
Well one network range is just the BT Hub and the other Network range is my whole wifi network.

I haven’t tried to change everything onto the network range but I think this was a problem when I first got it. That may be a solution, then I could setup port forwarding as you suggest, otherwise the BT Home Hub can’t see the Roon Nucleus?

So if you look on your Roon core what’s its IP address?
I’m guessing its ethernet connected and that cable goes to the home hub and its IP is 192.168.1.XXX.
If that’s the case set up port forwarding on the HomeHub.

Roon Core IP from DHCP
IP address:
DNS server:

So its looking to the Google Nest Hub for both the Gateway and DNS server
The Google Nest Hub has the BT Home Hub set for the WAN IP

I wonder if I try and get everything on (might take a while without loosing things!) Then the BT Home Hub should be able to see the Nucleus on

you could try this from the internet…

So have you got an network switch connected to the Google Mesh?
Im thinking you could have your ethernet network connected to the home hub and just use the mesh for wireless connections. This is how I have mt BT discs setup.

You can manually setup two port forward.

BT Router → Google Hub
Google Hub → Roon

That should work. Otherwise you need to get rid of the double nat. If the BT hub cannot run in bridge mode you’ll be forced to run the Google in AP or Bridge mode (I don’t know what they call). If you want to go down this path I can provide more details. Do note, in this mode, you lose all the parental, filtering, or what advanced features that thing provides.

Hi Phil
yes I have tried that … I can see the Nucleus on the Google Nest app. So I can setup forwarding on for port 55000, but thinking about it, it’s not really doing anything as The Nucleus and the Google nest are on their own network range.

if I test in Roon it has changed the error message to
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

But I guess this is just saying the Google Nest Hun isn’t passing the info through to the BT Home Hub.


I think my next option is to try and get the BT Router and the Google Nest on the same network ranges. Then I should be able to get the BT Home Hub to see the Nucleus and I may be able to setup port forwarding.

I assume I will then have the problem of multiple NAT or routers on the same network though, and I don’t think I can turn NAT off on either the BT Home Hub or the Google Nest!

nothing is ever simple, it will teach me not to mix and match rather than sticking to one manufacturer!

Hi Phil
no it doesn’t appear so, everything on the Google Nest is with just the BT router defined as a WAN connection on The BT router is plugged directly into one of the Google Nest hub network ports.

oooh that sounds like a good idea, I will try and set it up … I presume using 55000 for the ports on each?

Hi there
okay I tried setting up
BT Home Hub <> Google Nest port 55000
Google Nest <> Roon Nucleus port 55000

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

and it didn’t work … still the same error

good try though, I thought that should work


okay so I setup port forwarding on the BT Home Hub

I created a new “Game or App” called Google Nest
I selected the “Google Nest” app and as a device I put the IP address in

I then setup forwarding for both
55000 <> 55000
46685 <> 46685 << this is the port specified in Roon Arc

and it has worked!

I have a feeling the port in Roon is going to change so may need to look at this again.
I might be able to enter a range eg 45000-55000 <> 45000-55000

thanks for everyone’s help

1 Like

just changed the PORT in Roon to 55000 rather than the port it suggests, so it should now stay as 55000