Roon Arc connection problem with Fiio M15S

Roon Arc worked flawlessly in my previous Astell & Kern DAP, but my current Fiio M15S Roon Server cannot connect. This is strange since Fiio can access the Roon app and play all tracks there. Also, on my IOS Devices Roon Arc can be accessed. Appreciate help, thank you

Had similar issues with ARC on my M11 Plus. I just delete the apps data and set it up from scratch and it seems to work.

Was doing that several times with no effect- except that now the Roon app doesn’t work any longer. Initially it was listed as an endpoint and could be addressed from other endpoints. Now it is no longer an endpoint and has a strange listing in the settings. It can no longer get


addressed from other devices and when I try to play tracks from Roon library in Fiio, songs will load slowly and their play will stutter.
Wonder what might have happened.

Are you using the FiiO Roon app as it should see it show as Roon Ready device using that. It looks like you have enabled the Roon Android apps endpoint which isn’t what you should be using as it’s not bit perfect. FiiO have their own Roon app that makes the device Roon Ready. In Roon app disable the one that says this phone as that isn’t what you should be using and it’s likely set as a private zone which is why you can’t use it from any other Roon app.

2 Likes

Thank you for your suggestions which helped me to restore the Roon Ready function. Had not realised that the Fiio Roon app has to be enabled every time the device is turned on.

However

the problem with Roon Arc remains. Even though the settings show that the app can be accessed by Roon Server, the app will not connect and start a endless search for the server. At the end of my wits!

Yeah arc on some Android devices has been problematic, Androids network stack can be a bit funny. This has happened to phone users to. It only happens to me if I change something on my core. Might be one to check in with FiiO support.

What’s your Roon server running on?

Roon server is running on MacOs 14.5 and trouble-free. With my previous android DAP, I had no problems.
For the present problem I have contacted Fiio support.

1 Like

Fiio Support not helpful, required even a video to prove that I have a network connection. This I did, only to receive their photo that Roon Arc works in their network. No joke?

I’m a bit confused by what Fiio support told you.

Does this mean they just tried it on their own system and when it worked they didn’t offer any additional help?