Roon ARC connection problems

Hi, first of all, thank you for implementing the new Roon ARC functionality. I’m having trouble getting ARC to connect from outside my network. I have tried the different solutions suggested by the Roon team, but they have not worked. I include the error message that the system gives me to ask for help. I will appreciate a solution to be able to use ARC away from home. Thanks and kind regards.
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}

Moved to the support area
Please fill in the system information requested as well as your country, ISP and detailed networking information.

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Country: Spain
ISP: Jazztel
Roon Core Machine: Mac Mini M1
Networking gear: Livebox + (Orange)
Conected audio device: Cambridge Audio 851N
Number of tracks: 55.180
Description of issue: ARC error connecting

Have you followed the Roon ARC configuration guide?

Have you first updated the Core to Roon 2.0? And also updated the Remotes?

Do you have a fixed or dynamic IP address for your internet connection?

In my case (Roon ROCK on Intel NUC) my ISP (BT Halo FTTC) does not give residential customers a fixed IP address, so I updated my Core and Remotes to 2.0, and it all worked just as 1.8 had done, no issues.

I then had to implement a Dynamic DNS (DDNS), there are several free solutions. I have an ASUS RT5300 Router (not the BT Smart Hub which is supplied as standard). Asus have their own DDNS facility, which is free and very good, but I could have used any dyndns service. Having set up the DDNS, I had to create a port forward rule, as described in the Roon documentation. I then installed Roon ARC on my iPad, and initially it did not work as it could not connect. A few minutes adjusting the port forward rule sorted the issue and it worked.

I then installed Roon ARC on my android phone, it connected and configured, and now it all works.

I hope this process helps you out.

Hi, There have been some changes to my error message on the ARC connection. Below I put a screenshot in case any member can guide me to a solution. I still can’t use ARC outside of my house. Thanks in advance.

You haven’t opened up access to your core from external.
Have a look at this post

Hi, I finally managed to solve the ARC connection problem. I have made a port forwarding configuration in my router and ARC has connected. Thanks for your help. Kind regards.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.