Roon ARC connectivity issue (ref#P330R7)

What’s happening?

· I'm having trouble with Roon ARC

What best describes your issue with ARC

· Other

Describe the issue

Roon ARC unable to connect to my Roon server

Describe your network setup

ISP Router in Bridge mode to avoid Double NAT, TP-Link Deco Routers connected with RJ45 and Wifi points.

You use the plural to describe the TP-Link Deco Routers. Do you have more than one?

If so, then:

  • You may have enabled uPnP or set up port forwarding on the wrong router. This should be done on the Deco router than is connected to your ISP router.
  • You may still have a double Nat issue if both Deco routers are in router mode. The Deco router connected to the ISP router needs to be in Router mode. Any other Deco router should be in Access Point mode.

Also, if you have multiple Deco routers, how are they connected together ? Wired ethernet or Wifi?

As it stands, neither uPnP nor natPmP are enabled on the router (presumably [one of your] TP-Link Deco router[s]) that the Roon Server is connected to.

You will have to do one of:

  • Enable uPnP on this router
  • Set up a manual port forwarding rule to forward incomming TCP connections on port 55002 to your Roon server on 192.168.68.60.

If this does not work, then please copy and post the contents of the “Diagnostics data for Roon Support” box in full (your screen shot truncates it on the right hand side).

Hi, I ony have one Deco set as the main one. This is the one connected to the ISP router that is set in BRIDGE mode to avoid any double NAT. I can confirm that DOUBLE NAT is not the issue. Also uPnP is turned on for the network via the Main DECO hardwired to the ISP router in BRIDGE mode. And the MAIN DECO is set to router mode and hardwired to the other Deco to extend the range including the DECO that is hardwired to the MAC Mini that acts as the Roon CORE and server.

I can add that Roon Arc was working fine and that is just stopped working without my knowledge og anything that changed in my network setup.

I am not sure how to do a manual port forwarding rule?


These are the fields i can find under the NET Forwarding > Port Forwarding > Add rule

I would start with the following settings

Service Name: RoonARC
Internal IP: 192.168.68.60 (from the ip address of you Roon server in the screen shot in your first post).
Internal Port: 55002 (Again, from your original screen shot)
External Port: 55002
Protocal: TCP (Roon ARC does not employ UDP).

Thank you for your very quick response!

I tried what you suggested, but still the same:

{
“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“84.aaa.bbb.ccc”,“actual_external_ipv6”:“fde6:ddd:eee:fff:ggg:hhh:iii:jjj”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

OK. Thankyou.

Going back to your earlier statement:

From this statement, you have multiple DECO devices acting as a Mesh Wifi system.

You state that the DECO router connected to your ISP router (which is is bridge mode) is in Router mode. This is the DECO that you refer to as the Main DECO.

You then have a wired ethernet connection from the Main DECO to another DECO to extend WiFi range. This second DECO should be in access point mode.

At this point, I get a bit confused. Is your Roon Server connected to a third DECO (connected to the first pair by WiFi) or is it connected to one of the other two? If there is a third DECO, that should also be in access point mode. Only the Main Deco Router should be in Router mode. All other DECOs should be in Access point mode.

From your earlier posts, we know that the ip address of your Roon Server is 192.168.68.60. What is the lan side address of the Main DECO router? it should also be 192.168.68.x - differring from the Roon Server ip address only in the last number - represented by ‘x’. If this is not the case, then your other DECO router (or one of them) is still configured for router mode and, whilst you have elliminated the ISP router as the source of double NAT, the DECO routers themselves may be introducing double NAT. Please report the main DECO lan side IP address in a reply.

Next, If you go to a web site like What’s My IP Address, does the IPv4 ip address reported match the WAN side ip address issued to the MAIN Deco? If it does not, does the Main Deco IP address start with one of:

  • 192.168
  • 172.x (where x is in the range 16 to 31 inclusive)

If the Main DECO ip address starts with one of these, then the ISP router is still providing Routing functionality (not truly acting as a bridge) and is causing Double NAT.

If the Main DECO ip address does not start with 10., 172.x., or 192.168. and it does not match the ip address reported by What’s My IP Address, then it is probable that your ISP uses CG-NAT leading to a double NAT issue that is outside of your control.

If everything else is working on your network and you can’t get port forwarding to work (either manually or using uPnP) because of the presence of CG-NAT (or any other reason), then you could try using Tailscale VPN to get ARC working. You would need to install Tailscale on the MAC Mini that hosts your Roon Server and then install the Tailscale Client on the phone/tablets that you want ARC to work on. The use of Tailscale in this way is now a supported option and instructions can be found in the Roon Help Centre:

1 Like

Hi Wade, I can confirm that all other DECOs are in Access point mode.

The IP on my DECO router is 192.168.68.1 and my Roon Server is 192.168.68.60 inly different in the last number.

What’s My IP Address is different (IPv4) than on my DECO.
So, it’s the ISP Router that is still routing I guess and I will have to get Help from the ISP which is a shame because their severe is terrible :sweat_smile:

But thank you so much for you great help !!! and I will check back in case it’s possible to get rid of the routing but the connection still does not work.

Hello,

NOTE: You should not really publish the ip address discovered by Whats My IP on a public forum. I suggest you edit the above post if you can to remove it (I’m trying to write the remainder of this without compounding the privacy issue).

I don’t think, based on the information that you have provided above, that we can safely conclude that the ISP router configuration is wrong. It may be - but it may also be the use of CG-NAT on the part of the ISP.

The 192.168.68.1 ip address is the LAN side IP address of your main DECO router. On the Web Admin pages of your Main DECO, you should find the WAN side if address assigned to your DECO router by DHCP.

If your ISP router is truly in bridge mode and your ISP does not use CG-NAT, then the WAN side ip address of the router should be the same as that revealed by What’s My IP. Again, don’t report that here unless it begins with ‘10.’, ‘172.x.’ or ‘192.168.’. Please do report back to tell me whether the two ip addresses are the same or different.

If the WAN side IP address of your DECO is the same as that discovered by Whats My IP, then it means that you ISP router is correctly put into bridge mode and your ISP is not using CG-NAT.

If the WAN side IP address of your DECO router differs from that discovered by whats my IP, then it means one of:

  • Your ISP router is not correctly configured into bridge mode (if the WAN side ip address of your main DECO starts with ‘10.’, ‘172.x’. or ‘192.168.’).
  • Your ISP is using CG-NAT (if the WAN side ip address of your main DECO router does not start with ‘10.’, ‘172.x’. or ‘192.168.’).

In other respects, the fact that the LAN side ip address of your router (192.168.68.1) and the ip address of your Roon Server (192.168.68.60) are in the same subnet (ip address only differs in the last number) confirms that you have no other issues on your local network other than, possibly, the ISP router not being configured correctly. This is a step forward.

If you conclude from this that your ISP is using CG-NAT, then you only have two options:

  1. Contact your ISP and ask them to give you a public (possibly static) ip address that supports port forwarding. This, if your ISP can do it, may incur an increased monthly charge.
  2. Use tailscale to avoid the requirement to set up port forwarding as detailed in the link in my previous post.

Alternatively, if you conclude that it is the ISP router that is the issue, then there are three ways forward:

  1. Fix the ISP router configuration. I’m afraid that I can’t be a great deal of help here because I’m not familiar with the router in use.
  2. Set up double port forwarding. I will be able to help you with this if it is a route that you are compelled to follow.
  3. Bypass the port forwarding requirement by using Tailscale. Again the link to the Roon Help Centre article is given in my previous post.
2 Likes

Hi @Bjorn_Saunes,

@Wade_Oram has very helpfully provided thorough and accurate instructions - please let us know once you’ve had a chance to try the above and we’ll keep on the lookout for your reply.

Thank you so much @Wade_Oram I will have to look into this when I get back home in a few weeks or so.

@connor Indeed very helpful. Hope i am able to solve this to continue to enjoy Roon Arc.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.