Roon ARC doesn't connect to my core

Roon Core Machine

Running Windows 10 Home, 21H2
I configured local network modem to allow UPnP
Windows defender is installed on the NUC - should I change some firewall settings? I read in one article that there is some documentation explaining how to configure this with static IP and port forwarding. Can you send me the link to this documentation?


Networking Gear & Setup Details

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

Networking gear:
Type Wireless modem 3.0 (DOCSIS)
No additional routers - only some (passive) switches
no specific VPN’s or anything else

error was ‘listening port already in use’, but I clicked ‘reset’ - it changed the nr and the error disappeared, however, ARC wouldn’t connect yet.
I now updated the version as well (new version available) but no change in behavior in the app on my phone (Poor connection - try again).

Just to add: in the settings ARC tab - there’s no error anymore now and it says it has been securely connected.

OK, here’s an update:

  • I found the link to ARC port forwarding (located in fact in the Roon app/settings/Roon ARC tab/more info link below ‘Listening port’ and followed instructions
  • set my NUC on static IP
  • configured ports 55000-55010 on my modem (current listening port is 55002)
  • Reset my Roon ARC app on my phone & logged in again to connect to my core

… Success - it now seems to work - both when connected through WIFI on my home network and with 3G(!) via my not so good phone provider connection.

Glad to hear you got it working!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.